FAQ: Navigation - mkdir

somebody should review it because I have been stuck on this for an hour. I tried to refresh the bash, even started the course from the beginning and nothing works even if I’m on the corret path and did press ls. it’s pointless and frustrating.

100%, I’ve been here for an hour now and gone through the whole exercise 3 times now and it wont let me pass

This was rectified when I signed in today to study. When I was typing “ls” yesterday the list was completely different than today.

Hey, I am also stuck here… I have tried to get to 2014/dec in any possible way, and always “ls” the folder, bur it still gives me that I am missing the cmd ls…

This is what I have done so far,… Can ANYONE who has passed this test to post the correct answer so we can compare it? its frustrating and I want to move on to the next chapter :slight_smile:

$ ls 2014 2015 hardware.txt $ cd 2014 $ ls dec $ cd dec $ ls blog monitor.txt mouse.txt $


Hi, I am stuck here where I think I entered the correct code but it keeps returning error. Could anyone help? I have been stuck for a day now.

1 Like

Good morning! How did you reset it? Do you mean refresh the page? I did refresh so many times and also tried many suggestions listed above as well. All did not work and still return errors.

Need some help! I tried cd 2014/dec, press enter and then type ls, exactly like what the instructions say. Still nothing.

I’m in the same place buddy. I hope someone responds

$ pwd
/home/ccuser/workspace/blog
$ cd 2014/dec
$ pwd
/home/ccuser/workspace/blog/2014/dec
$ ls
monitor.txt mouse.txt
$

e yo, this sheet ain’t working …
" Did you run the command ls while in the dec/ directory to list the contents of the directory?"
well yes i did and I’m stuck on this step

It would help if you posted a screenshot of the code you’ve written.


Thank you

i have fixed it, go to top right corner, unstuck option>reset settings to clear any bugs.
now it worked

1 Like

Hi can u pls help me figure the first part of this exercise out i don’t know what im doing wrong, I’ve looked through every solution in the replies and NONE of them have worked.

So, you looked above and saw that people said they resolved this issue by resetting the exercise (which is under “Get Unstuck”)?

Whoever fails to pass “mkdir”, then most likely you have created “media” in the “blog” directory, you need to delete files and directories called “media” everywhere using the “rmdir” command

I spent 2.5 hours trying to figure out that the site didn’t tell me to delete the extra file to get to the next step. The terminal is sensitive and you cannot perform 3 tasks at once, you need to do one

Everyone must pass

  1. pwd
  2. cd 2014/dec
  3. ls
  4. CHECK WORK
  5. mkdir media
  6. CHECK WORK
  7. mkdir tv
  8. CHECK WORK
  9. NEXT!

If you do not go further, then most likely the problem is that you need to remove the media, and then repeat.

“rmdir media”
(if you have a lot of media, check and boolean remove “media” sequentially

1 Like

delete media and blog

i am stuck with mkdir, has anyone done this

Thanks

It would be helpful to introduce deletion commands and creation commands at the same time, considering that making a mistake for either will result in you being frozen from moving forward by Check Work without a command to fix your mistake.

1 Like

I’m having the same issue, the problem is that I cannot progress in the course. :frowning:


I reset the course many times, logged out, and logged in… I cannot move forward