FAQ: Navigation - mkdir

hello, i have the same problem and i tried going up two directories and i still says there’s no file or directory like of that type, what can i do?

Welcome to the forums!

Can you try using the pwd command and reply with what you get back? You might be starting off in the wrong directory.

yes it works, Thanks

Please what command can I actually use to navigate up 2 directories?

1 Like

Welcome to the forums!

To navigate up two directories (so to the grandparent directory), you would need to chain directories together. Since we can use .. to navigate up one directory, and can chain directories like so: directory1/directory2/directory3, how can you navigate up two directories?

Open this only if you can't figure it out/if you want to check if you're right.
cd ../..

I am having so much trouble. It is telling me to type in cd 2014/dec which I am doing and it is telling me it is wrong? I then did cd blog/2014/dec which was also incorrect? Is this a bug in the system?

Hello @joshuamac5721911868 ,

Try typing pwd to see which directory you are currently in.

This just happened to me: my pwd output /home/ccuser/workspace/blog/2015 and I tried a few things, but kept getting the same thing with error. I input cd … which put me back to /home/ccuser/workspace/blog and from there cd 2014/dec worked the way it’s supposed to.

(you’re prob an awesome coder now, this is just for other peeps like me rn)

1 Like

Well thank you, but I’m far from awesome! I still have a lot to learn; but I’ll get there and so will you!

Good luck and happy coding!:grinning:


1 Like

This is the only thing that worked for me. Thx!

Thanks this worked except I also needed to add cd before 2014/dec. This part was def very frustrating!


very helpful…thanks…

1 Like

thank you someone who actually helps

yeah idid refresh page
cd 2014/dec; ls
then it worked

1 Like

The same thing happened to me, and the best solution was to just reset the excersize and try typing the instruction again. It worked the second time around .

1 Like

This question annoyed the crap out of me, I don’t even know if it’s even important to learn this but thanks to some of you in this forum I was able to reset the exercise multiple times and start with a clear screen. Here’s the solution:
$ cd 2014/dec
$ ls
monitor.txt mouse.txt
$ mkdir media


Thanks. resetting the exercise really worked!

1 Like

thanks it really helped

Thank you… i just had to as the ls on a seperate line as i was in 2014/dec

1 Like

ls 2014/dec
It worked… thank you!!!

1 Like