FAQ: Navigation - cd II

This community-built FAQ covers the “cd II” exercise from the lesson “Navigation”.

Paths and Courses
This exercise can be found in the following Codecademy content:

Computer Science
Web Development
Build a Website with HTML, CSS, and Github Pages
Create a Front-End App with React

Learn the Command Line

FAQs on the exercise cd II

There are currently no frequently asked questions associated with this exercise – that’s where you come in! You can contribute to this section by offering your own questions, answers, or clarifications on this exercise. Ask or answer a question by clicking reply (reply) below.

If you’ve had an “aha” moment about the concepts, formatting, syntax, or anything else with this exercise, consider sharing those insights! Teaching others and answering their questions is one of the best ways to learn and stay sharp.

Join the Discussion. Help a fellow learner on their journey.

Ask or answer a question about this exercise by clicking reply (reply) below!
You can also find further discussion and get answers to your questions over in #get-help.

Agree with a comment or answer? Like (like) to up-vote the contribution!

Need broader help or resources? Head to #get-help and #community:tips-and-resources. If you are wanting feedback or inspiration for a project, check out #project.

Looking for motivation to keep learning? Join our wider discussions in #community

Learn more about how to use this guide.

Found a bug? Report it online, or post in #community:Codecademy-Bug-Reporting

Have a question about your account or billing? Reach out to our customer support team!

None of the above? Find out where to ask other questions here!

I’ve been clicking on the "Get Code Solution, but it won’t show up. So I’m coming here for help. I’m having issues navigating from 2015/feb** to **2015/jan

Below are the directions:

cd II

Instead of using cd twice in order to move from 2015 to memory , we can use it once and give it a longer argument:

$ cd jan/memory

To navigate directly to a directory, use cd with the directory’s path as an argument. Here, cd jan/memory navigates directly to the memory directory.

To move up one directory, we use cd .. :

$ cd ..

Here, cd .. navigates up from jan/memory/ to jan/ .

Instructions

We are currently in /home/ccuser/workspace/blog (you can check your location at any time using pwd ). Change the directory to the 2015/feb/ directory using:

$ cd 2015/feb

This brings us down one level to 2015 and then down once more into the feb directory.

Now we’re in 2015/feb , but what if we want to move to 2015/jan ? (You can reference the filesystem for this lesson here.)

This means that we have to go back up one level (to 2015 ), and then down into the jan directory. This could be accomplished using two distinct cd commands (one that moves us up and then another that moves us back down), but we’re going to do it using just one command.

Using a single cd command, navigate from 2015/feb to 2015/jan .

Navigate back to /home/ccuser/workspace/blog using a single cd command.

6 Likes

Hi Laceym,

were you able to figure this out? I"m having the same issue.

Thanks,

1 Like

Don’t forget the space before the … so its cd …/jan the its cd …/feb. 1 hour of my life spent figuring it out.

7 Likes

Hi, i’m having the same problem,
when i’m in 2015/feb
i try to move in 2015/jan with
/home/ccuser/workspace/blog/2015/jan

it works, using ls it show me
cpu.txt memory

what more they want? i reached the goal in one command

Did you find the solution? Can you post it for me?

Can you post the solution? i sitll have the problem even using the whole command line

Welcome to the forums. In the future, please refrain from posting multiple replies to a topic that ask the same thing (you can use @ if you want to mention/notify somebody).

This exercise explains how to move up one directory using cd .. and thus it expects you to use it when completing the steps. If cd .. can be used to move up one directory, and you can move through multiple directories using cd directory1/directory2 where directory1 and directory2 are the names of directories, what command do you need to use to move from 2015/feb to 2015/jan using one command?


Note: make sure that you navigate back to 2015/feb before trying to navigate to 2015/jan when trying again.

I think there is a bug here. I’m having the same issues as everyone above and understand that I need to move up the directly tree before going to cd 2015/jan. But it will not accept the answer and I can’t advance to the next step.

1 Like

Welcome to the forums!

I was able to pass this exercise without any issues when I worked through the course. What was the exact command you used?

I use cd 2015/jan. Am I right. I still stuck as it

Welcome to the forums!

In this exercise, you learnt about .. and how you can move to the parent directory by using it. cd 2015/jan is incorrect; what would be the correct solution that implements ..?

Hint

If we can use .. to navigate up one directory, then back down into another one, (as shown below) how can you apply this to the current situation?

cd ../directory

thanks, Victoria, after 15m testing, I finally found the correct one, it is cd 2015/feb, then cd…2015/jan. Move on…:slight_smile:

1 Like

Hello, I’m having the same issue and the solution
cd 2015/feb
cd…2015/jan
did not work for me! Can you help me on the issue?
Thanks

Hello Cferreira264, The solution is actually very easy. I also struggled a lot but I could solve the problem after one hour. Concentrate in cd … (only two points) and then you’ll have the answer. Greetings

Dear Cloudsolver42551, Thank you! It worked!
Regards!
Carlos

here you go, solution: cd …/jan

Welcome to the forums. Please refrain from posting solutions on the forums; we want to encourage others to solve the exercises themselves.

Hello. So I figured this out but just curious: why doesn’t the “Get Code Solution” option work? I selected it several times and nothing happened. Anyone know why?

Welcome to the forums!

The button does work. However, you aren’t shown what the solution is because of the nature of these modules. You’re working in the terminal, not a code editor. Commands that are written in the terminal don’t get saved as text whereas the code you write in a code editor does. Therefore, the button only works to allow you to advance to the next exercise without showing the solution.