FAQ: Local Setup with React Native - Creating a React Native App

This community-built FAQ covers the “Creating a React Native App” exercise from the lesson “Local Setup with React Native”.

Paths and Courses
This exercise can be found in the following Codecademy content:

Learn React Native

FAQs on the exercise Creating a React Native App

There are currently no frequently asked questions associated with this exercise – that’s where you come in! You can contribute to this section by offering your own questions, answers, or clarifications on this exercise. Ask or answer a question by clicking reply (reply) below.

If you’ve had an “aha” moment about the concepts, formatting, syntax, or anything else with this exercise, consider sharing those insights! Teaching others and answering their questions is one of the best ways to learn and stay sharp.

Join the Discussion. Help a fellow learner on their journey.

Ask or answer a question about this exercise by clicking reply (reply) below!
You can also find further discussion and get answers to your questions over in #get-help.

Agree with a comment or answer? Like (like) to up-vote the contribution!

Need broader help or resources? Head to #get-help and #community:tips-and-resources. If you are wanting feedback or inspiration for a project, check out #project.

Looking for motivation to keep learning? Join our wider discussions in #community

Learn more about how to use this guide.

Found a bug? Report it online, or post in #community:Codecademy-Bug-Reporting

Have a question about your account or billing? Reach out to our customer support team!

None of the above? Find out where to ask other questions here!

Hi :slight_smile:
I have followed video instructions but got this:“The operation was rejected by your operating system. npm ERR! It is likely you do not have the permissions to access this file as the current user”
I started to read forums but got very many annoying for me explanations as I am a newbie.
Could someone using macOs please help me with this exercise so I could move on. Thank you in advance!


sudo npm install -g expo-cli --global

and then it will ask you to type in your password


Tried typing in the terminal: expo init hello-world

Said, bash: expo: command not found



Happened to me as well. Can somone plz help us out?

worked, thank you !!!