FAQ: Learn React Router v6 - Installing React Router

This community-built FAQ covers the “Installing React Router” exercise from the lesson “Learn React Router v6”.

Paths and Courses
This exercise can be found in the following Codecademy content:

React Router
Learn React Router v6

FAQs on the exercise Installing React Router

There are currently no frequently asked questions associated with this exercise – that’s where you come in! You can contribute to this section by offering your own questions, answers, or clarifications on this exercise. Ask or answer a question by clicking reply (reply) below.

If you’ve had an “aha” moment about the concepts, formatting, syntax, or anything else with this exercise, consider sharing those insights! Teaching others and answering their questions is one of the best ways to learn and stay sharp.

Join the Discussion. Help a fellow learner on their journey.

Ask or answer a question about this exercise by clicking reply (reply) below!
You can also find further discussion and get answers to your questions over in Language Help.

Agree with a comment or answer? Like (like) to up-vote the contribution!

Need broader help or resources? Head to Language Help and Tips and Resources. If you are wanting feedback or inspiration for a project, check out Projects.

Looking for motivation to keep learning? Join our wider discussions in Community

Learn more about how to use this guide.

Found a bug? Report it online, or post in Bug Reporting

Have a question about your account or billing? Reach out to our customer support team!

None of the above? Find out where to ask other questions here!

I have downloaded the starting code and when I executed npm install in my terminal I get this:

"PC:\Users\jacma\OneDrive\Desktop\Jake’s Folder\Coding Projects\react_router_v6_lesson_starting_code> npm install

up to date, audited 17 packages in 1s

found 0 vulnerabilities"

Yet node_modules doesn’t appear anywhere in the vscode folders.

Does anyone have any ideas of a solution for this?

1 Like

Because of compatibility issue this whole routing chapter is totally redundant. Please update your material, it is extremely frustrating and time consuming having to deal with such issues that should be dealt by you.

1 Like

Hey folks, I am facing issues installing the react router, the terminal stops at the step ‘’/ reify:fsevents: sill reify mark deleted [‘’ tried to start over several time and it still not working, is there a way I can fix it ?
Many thanks.

hey made sure you ‘cd’ into starting_code folder before you ‘npm install’ :slight_smile: hope this helps

Is this course still relevent? it fails to work on install and reading comments its out of date?

My pathing: - create folder on desktop - open the folder in vscode - open terminal - npx create-react-app file - cd file - open package.json in vs code - cd file - npm install - npm install react-router-dom@6 --save - npm start.

this loads the standard react app in local host - NOT what it shows on the tutorial - in the src folder in vs code there is no app folder - in App.js there is no const router or return statement. please help

Is there any help anywhere on this site?? Iv posted a few times looking for help, iv seen many many unanswered questions going back 18 months etc. Where is the help and support for students? Its non-existant, FreeCodeCamp is so much better. Im stuck on this out of date React module, unable to complete it, i come on here to get help and see people facing the same issues with 0 responses, 0 help whatsoever. THIS IS NOT ACCEPTABLE FOR A PAID SERVICE!!!

I am also wanting help with this particular exercise. I have installed the dependancies as instructed and have a lot of vulnerabilities, including a few critical ones. Surely this means that the material is out of date and needs attention?

I will persevere and see how far I can get with the course in it’s current state.

The lesson is outdated, i managed to run the zip package like in the video by altering the package.json file in the object “scripts” in this manner:
“scripts” : {
“start”: “react-scripts –openssl-legacy-provider start”,
“build”: “react-scripts –openssl-legacy-provider build”,
“test”: “react-scripts test”,
“eject”: “react-scripts eject”
I hope it works for everyone