FAQ: Learn Python - Battleship - You win!

This community-built FAQ covers the “You win!” exercise in Codecademy’s lessons on Python.

FAQs for the Codecademy Python exercise You win!:

Join the Discussion. We Want to Hear From You!

Have a new question or can answer someone else’s? Reply (reply) to an existing thread!

Agree with a comment or answer? Like (like) to up-vote the contribution!

Need broader help or resources about Python in general? Go here!

Want to take the conversation in a totally different direction? Join our wider discussions.

Learn more about how to use this guide.

Found a bug? Report it!

Have a question about your account, billing, Pro, or Pro Intensive? Reach out to our support team!

None of the above? Find out where to ask other questions here!

Other FAQs

The following are links to additional questions that our community has asked about this exercise:

  • This list will contain other frequently asked questions that aren’t quite as popular as the ones above.
  • Currently there have not been enough questions asked and answered about this exercise to populate this FAQ section.
  • This FAQ is built and maintained by you, the Codecademy community – help yourself and other learners like you by contributing!

Not seeing your question? It may still have been asked before – try (search) in the top-right of this page. Still can’t find it? Ask it below by hitting the reply button below this post (reply).

I’m having an issue where the code times out after I enter my guess for the row. I can’t enter my guess for the column and can’t continue to the next part unless I click solution. Has this happened to anyone else?

Same here with the same error. I think it is any call to using raw_input causing the hang, no idea why though because it was working fine up until yesterday.
Submitted a bug report, recommend you do the same so it gets flagged.
Cheers

hello richy, am currently experiencing the same problem. how do i submit a bug report to the codecademy team?

i am also having problems with this. i have since quit python on this website.

Yep, I have the same problem. and I’m getting the same error message. I gave up and got the solution, but when I run it, I still get exactly the same error message.