FAQ: Hello World: Java - Compilation: Catching Errors

Welcome to the forums!

The terminal is the right-most panel.


On another note, this community encourages users to solve problems and complete the lessons themselves, rather than simply using the Get Solution option. That should be a last resort.

IM here to help
your screen should be divided in 3 areas
the left side is the learning section
the middle section is where the code goes
the right section is the terminal
type ( javac. Compiling.java) into the empty terminal space

2 Likes

also push enter when you type javac compiling.java

I’ve done everything you said and it’s still not working for me.

Welcome to the forums! Can you post the exact commands you used?

thanks so much for replying but I got it now.

1 Like

This worked! Thanks itch_aitch.

Something that helped me is check the code read through it. In my case there was no errors in the starting code which didnt let me get the terminal error in order to procceed . If your code looks correct remove the semicolon from the 3rd println command and compile , terminal will return an error , then click Check Work . Hope this helps :smile:

hello there i think the problem with all of you is the coding panel is a correct code and the terminal cant get a problem so the terminal to find an error go to the coding space and delete one semicolon

i had the same issue, what worked for me , i entered to solution they have and i just replace their answer by mine … and it worked i was stuck there for long time

youre putting the code wrong, you have to type in “java Compiling;” you added a C on the end of the first java.

I didn’t understand why we put ls in the terminal for checking errors?

Welcome to the forums!

In this exercise, we don’t use ls to check for errors. Step 2 simply uses ls to demonstrate that, when there’s a compile-time error, the program does not compile successfully and does not generate a .class file.

On the first exercise, I type the command exactly as it says (javac Compiling.java) and hit enter. It tells me about the error with the semicolon as it should. However, when I click ‘Check Work’ afterward, it says ‘Did you run javac Compiling.java in the terminal?’

I have also tried copying and pasting the command from the lesson into the terminal and running that.

Welcome to the forums! You might consider resetting the exercise (there’s a button to do this at the bottom of the middle pane). If that doesn’t work, a workaround would be to click Get Unstuck, then Get Solution to pass.

I’m pretty sure this exercise is bugged. I’ve tried running javac, gotten the error, fixed the error, compiled successfully, run ls, tried resetting the exercise, refreshing the page, tried two different browsers - no matter what I do, the first task won’t complete.

Same here, tried countless times to do exactyl as they say, stil message pops up “Did you run javac Compiling.java in the terminal?”
I can’t progress unless something will get fixed

When I put javac Compiling.java , it did not work. I kind of tried to play around with it… accidentally deleted the file. Now the file does not show up nor will it comeback. I’ve tried to reset it many times but the file still does not come back. Is there anything else I can do to get the file back?

Does not work to enter “javac Compiling.java”, tried many work arounds, the only thing that seemed to work, after 15-minutes, was to click the “Get Unstuck” at the top right, then seeing the solution, and then accept code as replacing the original code. Might have to do that a couple of times? Good luck

Hey all!

Thanks for letting us know.

The team is aware of the issue and should have it fixed soon.

Thanks for your patience!