FAQ: Hello World: Java - Compilation: Catching Errors


This community-built FAQ covers the “Compilation: Catching Errors” exercise from the lesson “Hello World: Java”.

Paths and Courses
This exercise can be found in the following Codecademy content:

Learn Java

FAQs on the exercise Compilation: Catching Errors

There are currently no frequently asked questions associated with this exercise – that’s where you come in! You can contribute to this section by offering your own questions, answers, or clarifications on this exercise. Ask or answer a question by clicking reply (reply) below.

If you’ve had an “aha” moment about the concepts, formatting, syntax, or anything else with this exercise, consider sharing those insights! Teaching others and answering their questions is one of the best ways to learn and stay sharp.

Join the Discussion. Help a fellow learner on their journey.

Ask or answer a question about this exercise by clicking reply (reply) below!

Agree with a comment or answer? Like (like) to up-vote the contribution!

Need broader help or resources? Head here.

Looking for motivation to keep learning? Join our wider discussions.

Learn more about how to use this guide.

Found a bug? Report it!

Have a question about your account or billing? Reach out to our customer support team!

None of the above? Find out where to ask other questions here!


The terminal does not work, so I can’t proceed. I cannot click inside of it, because there seems to be something loading constantly (icon on top of the screen). Kind of lame to run into something like this so early on, as you can’t skip the exercise…


Same here :frowning: I hope it will be fixed


Having the same issue - plus we cannot bypass the exercise to move on.


I’m having an issue with the terminal - I’m typing “javac Compiling.java” as instructed but the terminal just says “command not found” in an infinite loop. Can’t skip the lesson either, disappointing.


I don’t know if any of you are still having issues with the exercise, but I got stuck on the second instruction.
What worked for me was to add the semicolon (as the third instruction states) than type ls in the terminal and press enter. This was accepted and I moved on to the next instruction.
That still left me with the third instruction, which I’d already done to get passed the second. Eventually I removed the semicolon, added it again and clicked on check work at the bottom of the terminal.
That worked for me and I hope it’ll help some of you as well.