FAQ: Git Teamwork - git push

This community-built FAQ covers the “git push” exercise from the lesson “Git Teamwork”.

Paths and Courses
This exercise can be found in the following Codecademy content:

Web Development

Learn Git

FAQs on the exercise git push

There are currently no frequently asked questions associated with this exercise – that’s where you come in! You can contribute to this section by offering your own questions, answers, or clarifications on this exercise. Ask or answer a question by clicking reply (reply) below.

If you’ve had an “aha” moment about the concepts, formatting, syntax, or anything else with this exercise, consider sharing those insights! Teaching others and answering their questions is one of the best ways to learn and stay sharp.

Join the Discussion. Help a fellow learner on their journey.

Ask or answer a question about this exercise by clicking reply (reply) below!

Agree with a comment or answer? Like (like) to up-vote the contribution!

Need broader help or resources? Head here.

Looking for motivation to keep learning? Join our wider discussions.

Learn more about how to use this guide.

Found a bug? Report it!

Have a question about your account or billing? Reach out to our customer support team!

None of the above? Find out where to ask other questions here!

The exercise comes up with a tick - however my output from git is not the same as the output the tutorial says I should have, any ideas?

1 Like

reload the page again

2 Likes

Hi there!

Your first entry on the command line is “cd my quizzes”. Bash tried changing into the directory “my”. Unfortunately there is no such directory, as indicated by the output on the next line.

As branch names must have no whitespaces (aka spaces), this first line should have been “cd my-quizzes” if your branch is called “my-quizzes” as per the exercise.

My step 2 is not working. Can anyone please share the command which you have used in that.

4 Likes

The directory name in this lesson speciffically is different from what is in the instructions, as can be seen in my screen-shot.
Why that is, I cannot imagine.

If you can’t pass the second check-box, try using the following path for origin:

/home/ccuser/workspace/curriculum-a/science-quizzes

4 Likes

I’ve tried pasting your path and its still not going for me. Seems like a bug

1 Like

THanks for help :slight_smile:

I fixed my mistake but even when I get the output it wants I am incorrect. Can someone tell me why I can’t complete

this? I went ahead and completed the projects and quiz.

1 Like

I found the solution to this. It is completely wrong to what the steps say and the output gives an error but it gives a green check so I can continue. Instead of going to the directory my-quizzes like it wants got to science-quizzes once there input git push origin bio-questions

6 Likes

Apologies for a belated reply, I can see how the instructions might be a little confusing but it makes sense if you follow the previous lessons carefully. An explanation (sadly not a brief one) is below if you wanted to do this correctly.

To start with there is a directory called science-quizzes purportedly written by a colleague, ‘Sally’, and set up as a git repo. You clone this repository to a new directory my-quizzes (back in lesson 2). Note that you have a default remote (tracked repo address for push/pull due to the clone) in your new repo my-quizzes named origin at this point which points back to the original folder due to the clone (described in lesson 3).

In lesson 6 you start working on your own changes after creating a new branch bio-questions (this branch exists only in your my-quizzes repo at this point).

In this specific lesson (7) you move into your own directory my-quizzes which by now has a new branch. You then want to push this new branch to the original repo; the science_quizzes directory. Since the remote already exists under the name origin (due to the clone) you can push with the command: git push <remote> <branch> replacing the remote name and branch to the given ones.

I think there is a small amount of confusion here because the test is probably just checking you enter the exact text expected (of the form git push <remote> <branch>). Passing the lesson might technically require just that but understanding and correctly pushing a branch should be your main goal.

If you then moved to the original repo directory cd ../science-quizzes and check the existing branches (git branch -a for example provides all local/remote branches) you should now find the bio-questions branch available in the original repo (this is the important bit).

A previous comment mentioned the parent directory changes name (curriculum to curriculum-a)-FAQ: Git Teamwork - git push - #6 by mariaburmeister. This does seem to happen (lesson4) for some reason but it shouldn’t affect the workflow as the new repos have the correct remote address anyway (though I’ve no idea why it changes either).

Step 2 had me stumped for a little bit, but basically step 2 is asking you to push the current branch you’re working on.

So all you need to do is find the name of the branch you’re using by typing

git branch

then the syntax provided in the lesson. Screenshot attached for reference.

Hope this helps folks :slight_smile:

11 Likes

Thanks ever so much - I was having the exact same problem as you guys above - I could not get past question 2. But thanks redcat817 for helping me to resolve this - i followed your suggestions and the check box gave me the green light and I was able to move on.

1 Like

Thanks! that was helpful

thanks, this worked on mine,

1 Like

Hi,

I am at the second point of this section: https://www.codecademy.com/paths/back-end-engineer-career-path/tracks/fscp-git-and-github-part-ii/modules/fscp-git-teamwork/lessons/git-teamwork/exercises/git-push

When I add “git push” it is not working

The instructions are:

2.

Push your branch up to the remote.

In the output, notice the line:

To /home/ccuser/workspace/curriculum/science-quizzes * [new branch]      bio-questions -> bio-questions

Git informs us that the branch bio-questions was pushed up to the remote. Sally can now review your new work and can merge it into the remote’s master branch.

I JUST FOUND THE ANSWER IN THE PICTURE ABOVE

“git push origin bio-questions”

Yes, i finally was able to get thru it

1 Like

1 Like

This was pretty confusing the way everything was worded but this worked for me as well, thank you!

thanks so much for this clear and concise explanation