FAQ: Getting Started - Hello Rails I

This community-built FAQ covers the “Hello Rails I” exercise from the lesson “Getting Started”.

Paths and Courses
This exercise can be found in the following Codecademy content:

Learn Ruby on Rails

FAQs on the exercise Hello Rails I

There are currently no frequently asked questions associated with this exercise – that’s where you come in! You can contribute to this section by offering your own questions, answers, or clarifications on this exercise. Ask or answer a question by clicking reply (reply) below.

If you’ve had an “aha” moment about the concepts, formatting, syntax, or anything else with this exercise, consider sharing those insights! Teaching others and answering their questions is one of the best ways to learn and stay sharp.

Join the Discussion. Help a fellow learner on their journey.

Ask or answer a question about this exercise by clicking reply (reply) below!

Agree with a comment or answer? Like (like) to up-vote the contribution!

Need broader help or resources? Head here.

Looking for motivation to keep learning? Join our wider discussions.

Learn more about how to use this guide.

Found a bug? Report it!

Have a question about your account or billing? Reach out to our customer support team!

None of the above? Find out where to ask other questions here!

I’ve done the 3 steps on page 1…
rails new MySite bundle install
$ rails server

Everything in the terminal window looks fine.
Yet, at http://localhost:8000 I only see the messages for “This site can’t be reached … localhost refused to connect.”

I’m expecting to see a default page, “Welcome aboard”.
If I search the directory where all the RoR directories are for the text " You’re riding Ruby on Rails!" that is not found.

I did go through apache2 setup, and I do see my “Hello World!” page I created, at http://localhost

I’m on a Mac.
What could I look into, next?
Shouldn’t RoR be displaying that default page, now, at localhost:8000?

1 Like

Am I supposed to see something other that what is on the pic below when doing this lesson? If so, there are not instructions on how I need to fix it. Please help!
image

anybody home?

i did all the exercises yet the Next button is still greyed out!!

bump!!
is there a mod here??

Hey @bad.banana!
Have you tried reloading the page, restarting your browser, clearing your cookie cache, and restarting your computer? And, if you’re not already, try using the Chrome web browser/
If it still doesn’t work, I recommend submitting a bug report.

been there, done that.
i have to reset the session and go back to square one to make it work!

bummer.

Hello, did you ever find out what the issue was? I’m having the same problem. Cheers

Try resetting the progress and see if it works. It has happened to me and looks like it’s the only workaround I’ve found :man_facepalming:t2: