FAQ: Environment - Intro to Environment

This community-built FAQ covers the “Intro to Environment” exercise from the lesson “Environment”.

Paths and Courses
This exercise can be found in the following Codecademy content:

Web Development

Learn the Command Line

FAQs on the exercise Intro to Environment

There are currently no frequently asked questions associated with this exercise – that’s where you come in! You can contribute to this section by offering your own questions, answers, or clarifications on this exercise. Ask or answer a question by clicking reply (reply) below.

If you’ve had an “aha” moment about the concepts, formatting, syntax, or anything else with this exercise, consider sharing those insights! Teaching others and answering their questions is one of the best ways to learn and stay sharp.

Join the Discussion. Help a fellow learner on their journey.

Ask or answer a question about this exercise by clicking reply (reply) below!
You can also find further discussion and get answers to your questions over in #get-help.

Agree with a comment or answer? Like (like) to up-vote the contribution!

Need broader help or resources? Head to #get-help and #community:tips-and-resources. If you are wanting feedback or inspiration for a project, check out #project.

Looking for motivation to keep learning? Join our wider discussions in #community

Learn more about how to use this guide.

Found a bug? Report it online, or post in #community:Codecademy-Bug-Reporting

Have a question about your account or billing? Reach out to our customer support team!

None of the above? Find out where to ask other questions here!

Hi everyone,

I’m hoping you can shed some light on why nano does not work for me, please see the attached snippet… In the exercise it says to type ctrl + o but nothing happens, I also tried to exit with ctrl + x or z but no luck . I have pressed the keys as well hoping it will work that way… :relaxed:

Please note I do have a problem with my keyboard ( Ctrl +C does not work…I mean any Ctrl Commands…Sticky keys :grimacing:) I’ve tried fixing it sooo many times but it’s just not having it.

Thanks in advance :v:


Mighty Google helped me with an alternative

^X      (F2)            Close the current file buffer / Exit from nano
^O      (F3)            Write the current file to disk

I still don’t understand why typing it would not work so if anyone knows please I am very curious :smiley:

Update 2 :ok_woman:

The ^ stands for the Ctrl key.

PS: I tried this way but still no luck, the only progress I can make is with F3 and F2 :upside_down_face:

I think that in all their best efforts, the people who create these lessons are giving instructions for humans rather than computers. So they aren’t giving instructions as they would computers. Many of us programming minded people do however think like computers when following instructions and so we follow exactly as they are written.

It also did not work for me when I followed exactly as instructed. So I had to go into human mode and make assumptions.

after you type “Hello, I am nano.” press the enter key
then press ctrl key and the letter O at the same time.
Press Enter key
press ctrl key + x at the same time.
type cat hello.txt


I don’t get any nano menu and nothing works (Mac) :confounded: – Edit: it didn’t work in Chome, so I tried Safari and that worked.

Guys, need help. I have done everything right here and I can’t move on the the next part of the course. I added this sentence exactly the way it is. I saved it in hello.txt. When I type cat hello.txt, everything works ok, but I still get the bug: “Did you edit hello.txt in nano? And did you use the cat command to verify?”.
I have tried restarting the terminal, changing the browser. I removed the file and made a new one. I don’t know what else to do.


Did you fix it? Having the same issue here, need some help!

Nope. Apparently a lot of people have the same problem. Try to send the bug as well, maybe someone will debug it.

Already did that.I was looking on the support page if there is any live chat option but i don’t see this option,tried on chrome aswell/safari same bug.there isn’t any way to skip to the next exercise,right?

I had a challenging time with this at first. Note for those using a Mac: utilize the “control” button and not the “cmd” button for Ctrl.

I had the type in the actual name of the file I was editing. If you ctrl + h for help then it explains what to do far better than the task description!

Also why use nano when we could use vim? Does not compute.