FAQ: Environment - Aliases I

This community-built FAQ covers the “Aliases I” exercise from the lesson “Environment”.

Paths and Courses
This exercise can be found in the following Codecademy content:

Web Development

Learn the Command Line

FAQs on the exercise Aliases I

Join the Discussion. Help a fellow learner on their journey.

Ask or answer a question about this exercise by clicking reply (reply) below!

Agree with a comment or answer? Like (like) to up-vote the contribution!

Need broader help or resources? Head here.

Looking for motivation to keep learning? Join our wider discussions.

Learn more about how to use this guide.

Found a bug? Report it!

Have a question about your account or billing? Reach out to our customer support team!

None of the above? Find out where to ask other questions here!

I can’t get pass question 2, anyone with the same issue. It seems that I’m not saving the file proprelly.

6 Likes

Same here, won’t progress. I’m wondering if it’s because Chrome opens a pop-up “Open” window when I use Ctrl-O which is upsetting CodeAcademy.

1 Like

was anyone able to solve this. I had the same issue. Couldnt get past step 2

I managed to get past it - although it states to put the alias beneath the previous alias, it will only progress if the alias in Q2 is the only line.

I tried that and it still won’t progress for me :confused:

1 Like

I disabled short cut keys for my laptop which stopped the window coming up. But I still wasn’t able to pass the step. Then I saved, exited and cleared and that moved me on. Not sure why but at least it’s done!

1 Like

Cant pass the second step … codecademy is not marking my progress @mtf pls review the lesson

I can confirm you can pass the 2nd step if you will:

1.remove all previous lines from nano, and write alias hy=“history” as only line

  1. exit nano (ctrl + o)

  2. clear bash

  3. enter nano again - the only line will appear - it should mark step 2 as finished.


Tip: If you will have similar problems with step 3. try to copy-paste the alias code instead of retyping it

Also as we are removing the previous alias to proceed - in pre-final step the ‘‘hy’’ alias won’t work as history command

Sorry, but I am not able to pass my 3rd step. Your 2nd step is good but 3rd one is not working.

Hello @cloud0358869526!

Could you elaborate on what issue you are having?

Has anyone got passed third step in the environment section.

Just ask for code solutions from there and you will pass it yeah!!!
thank me later.

Hello @hanisntsolo and welcome to the Codecademy Forums!

Could you describe the issue you are having and what exercise and step you are stuck on? There doesn’t seem to be a third step on the Environment exercise, unless you are referring to the third exercise (Bash Profile) in the Environment unit.

I’m not sure what you are referring to here. I was able to complete the course without getting any solutions from Codecademy. I would advise everyone to ask for help here on the forums if they have any questions, it’s a great way to learn!

This lesson is completely broken, I don’t know if it’s because I’m using chrome but it is entirely non functional.

Hello @tera7061251269 and welcome to the Codecademy Forums!

What issues are you having?

I am getting permission denied when I get on to step two, even though it was working just fine in the previous lesson.

Capture

Providing the file name on its own is asking for that file to be run as a script. If you’re trying to update your current terminal environment you’d want to be using source ~/.bash_profile and for editing the text it’s probably easiest to use a built-in text editor like nano ~/.bash_profile or vi ~/.bash_profile depending on your preferences.

1 Like

Hello! I am completely stucked at the second exercise of Aliases |. There is a bug in the program. I tried to report it several times through “Help options”, no reaction at all. It is noted that the first exercise is completed, when trying to perform the second exercise, it is displayed “Make sure your alias is named pd, for the pwd command”… YES! it is! But the second exercise is marked wrongly resolved. And no way to move forward. No code solution for this exercise. No option to undo the first exercise…