FAQ: Command Line Basics - cp

This community-built FAQ covers the “cp” exercise from the lesson “Command Line Basics”.

Paths and Courses
This exercise can be found in the following Codecademy content:

Learn Raspberry Pi

FAQs on the exercise cp

There are currently no frequently asked questions associated with this exercise – that’s where you come in! You can contribute to this section by offering your own questions, answers, or clarifications on this exercise. Ask or answer a question by clicking reply (reply) below.

If you’ve had an “aha” moment about the concepts, formatting, syntax, or anything else with this exercise, consider sharing those insights! Teaching others and answering their questions is one of the best ways to learn and stay sharp.

Join the Discussion. Help a fellow learner on their journey.

Ask or answer a question about this exercise by clicking reply (reply) below!
You can also find further discussion and get answers to your questions over in #get-help.

Agree with a comment or answer? Like (like) to up-vote the contribution!

Need broader help or resources? Head to #get-help and #community:tips-and-resources. If you are wanting feedback or inspiration for a project, check out #project.

Looking for motivation to keep learning? Join our wider discussions in #community

Learn more about how to use this guide.

Found a bug? Report it online, or post in #community:Codecademy-Bug-Reporting

Have a question about your account or billing? Reach out to our customer support team!

None of the above? Find out where to ask other questions here!

I’m working on the lesson, COMMAND LINE BASICS cp.

Step 5 asks “Using a single ls command, look at the contents of the historical/ directory.” I’ve typed in ‘ls’, and I think, successfully listed the contents of the ‘historical/’ directory, but still can’t get a green checkmark. I’m not sure what I’m doing wrong.

Here is an example of my command line:

$ pwd
>> /home/ccuser/workspace/movies-rpi/drama/historical
$ ls
>> gladiator.txt  notorious.txt  ray.txt  selma.txt

I’m stuck at the same spot. Doing the same thing you are, not sure what is wrong. Were you able to get past it?

I just figured it out! Instead of changing directory into drama/historical and using the ls command, stay in the /movies-rpi directory and use ls drama/historical to list the files in the subfolders but stay in the current working directory.

$ pwd
>> /home/ccuser/workspace/movies-rpi
$ cp drama/biopic/ray.txt drama/biopic/notorious.txt drama/historical
$ ls drama/historical
>> gladiator.txt  notorious.txt  ray.txt  selma.txt

Great! Thank you for the help

I’m only on step one, but for some reason I can’t get past it. I’ve tried a bunch of times and nothing seems to be working even though I following all the instructions.

Nothing on this step is working. I’ve tried it so many times and the instructions are too confusing because they are saying opposite things.