FAQ: Browser Compatibility and Transpilation - Transpilation With Babel


#1

This community-built FAQ covers the “Transpilation With Babel” exercise from the lesson “Browser Compatibility and Transpilation”.

Paths and Courses
This exercise can be found in the following Codecademy content:

Introduction To JavaScript

FAQs on the exercise Transpilation With Babel

There are currently no frequently asked questions associated with this exercise – that’s where you come in! You can contribute to this section by offering your own questions, answers, or clarifications on this exercise. Ask or answer a question by clicking reply (reply) below.

If you’ve had an “aha” moment about the concepts, formatting, syntax, or anything else with this exercise, consider sharing those insights! Teaching others and answering their questions is one of the best ways to learn and stay sharp.

Join the Discussion. Help a fellow learner on their journey.

Ask or answer a question about this exercise by clicking reply (reply) below!

Agree with a comment or answer? Like (like) to up-vote the contribution!

Need broader help or resources? Head here.

Looking for motivation to keep learning? Join our wider discussions.

Learn more about how to use this guide.

Found a bug? Report it!

Have a question about your account or billing? Reach out to our customer support team!

None of the above? Find out where to ask other questions here!


#2

Hello,
I’m stuck with this exercise.

I don’t get it, where/how to write in the Terminal?
Please see the screenshot.
Initially I thought that the Browser might be faulty, but I tried Google Chrome and same issue occurs.

Thank you!
npm|690x334


#3

Update:
I’ve found a solution.
So for some reason the Terminal did not load properly (even in the 2nd browser), after a few page refresh it worked fine.


#4

When I type:

npm run build
and then:

./lib/main.js
I am getting message that permission was denied.
Anybody got same problem or know solution?
See ssCapture2