FAQ: A Night at the Movies - Setting Up

This community-built FAQ covers the “Setting Up” exercise from the lesson “A Night at the Movies”.

Paths and Courses
This exercise can be found in the following Codecademy content:

Learn Ruby

FAQs on the exercise Setting Up

There are currently no frequently asked questions associated with this exercise – that’s where you come in! You can contribute to this section by offering your own questions, answers, or clarifications on this exercise. Ask or answer a question by clicking reply (reply) below.

If you’ve had an “aha” moment about the concepts, formatting, syntax, or anything else with this exercise, consider sharing those insights! Teaching others and answering their questions is one of the best ways to learn and stay sharp.

Join the Discussion. Help a fellow learner on their journey.

Ask or answer a question about this exercise by clicking reply (reply) below!

Agree with a comment or answer? Like (like) to up-vote the contribution!

Need broader help or resources? Head here.

Looking for motivation to keep learning? Join our wider discussions.

Learn more about how to use this guide.

Found a bug? Report it!

Have a question about your account or billing? Reach out to our customer support team!

None of the above? Find out where to ask other questions here!

I am getting “execution expired” for this exercise (and I was only able to get to it by commenting out the previous one because it was also giving me “execution expired”).

It will help immensely if we can see your raw code. Please copy and paste into a reply.

In the meantime, we could hazard a guess that there is something circular going on that the interpreter aborted.

I am getting this message regardless of my code. Even if my code is:

a = “a”

I get this message.

And I get the same message for the previous page (the “example” code).

try reloading the page, clearing your cookie cashe, and restarting the browser. :smiley: Just the basic trouble shooting list

1 Like

I have already done all these steps.

Can you give me the link to the exercise? Ik its probably somewhere in the topic, but I would like the exact one you are on.

Sure! There you go: https://www.codecademy.com/courses/learn-ruby/lessons/a-night-at-the-movies/exercises/what-youll-be-building-5

1 Like

What the heck? Same thing is happening to me… Lets see if we can get one more person to try it out and see if it happens to them:

Do you guys think that it is a codecademy website bug ? Because I have the same problem and I can’t understand what is wrong. I just tried your link and have also the same “execution expired” thing too.

1 Like

I had the same results last night. Seems any statement using .gets causes the execution expired message. I tried commenting the statements out that include .gets, and just assigning values to variables, and it worked fine. I’m guessing there is a problem with the site. I clicked on the help icon at the bottom right of the console, and submitted a bug report. If everyone does the same, hopefully it will attract the attention necessary to fix the bug.

2 Likes

I am also getting this same exact issue - but in the Putting the Form in Formatter section of Learning Ruby. I have submitted a ticket as well

4 Likes

I am having the same issue. Hopefully they will fix it ASAP

1 Like

Hi, I also have this issue and don’t know how to continue … I reported the bug via the help icon.

2 Likes

Good man! As long as we keep getting unique reports, their bound to notice it.

I had that issue too, even if the code was a=“a”, it would keep loading. However, it was solved by restarting the browser.

I’m getting this as well:
https://www.codecademy.com/courses/learn-ruby/lessons/a-night-at-the-movies/exercises/what-youll-be-building-5

Oddly enough I’m using the default code that comes up on page one but when I try to run it it returns: (I actually keyed in ‘display’ – no quotes – and hit enter but it didn’t display the word on the screen and after a few seconds displayed “execution expired”. This has been the case every time the code uses variable.chomp The chomp seems to be the issue. I woulld really love some input on how to work around this. It seems to have been an issue for some time now, judging by the dates of previous posts.

What would you like to do?
– Type ‘add’ to add a movie.
– Type ‘update’ to update a movie.
– Type ‘display’ to display all movies.
– Type ‘delete’ to delete a movie.
execution expired

If the exercise runs without chomp I’d be surprised. The problem is with, gets.

Actually its neither ‘gets’ nor ‘chomp’. I was reading thru older Forum entries and saw this little gem “Have you clicked in the terminal window?” it turns out that just because the cursor is blinking, its not in a position to gather any data. I clicked in the terminal window after clicking run, and was able to provide my input and the code ran just fine afterward. This little detail should be put in one of the FAQs (if it isn’t already) or make part of the course itself (if it isn’t already and I just missed it).

2 Likes

A post was split to a new topic: Why they are saying that you need to use .chomp