Exponents not working, possible bug


I am just starting out here and have become quite stuck.

Q). 6 people want 6 quilts and each quilt is 6x6 squares.

I know the answer is print(6 ** 4), however no matter what I write, the answer is returning 216 (in other words (6 ** 3). See pics below:

Screenshot 2022-10-07 at 11.53.22

What do I do?

I had to logout, quit Chrome and then come back to it.

Strange error.

It seems someone edited this, so I should make it extra clear in case anyone is reading this later.

I originally put in the wrong answer, I believe I had written (6 ** 2) * 6 and then saw my mistake and tried to correct it, but it refused to work until I went through the steps I described above.

To be completely honest here, having a hard time understanding what the actual issue is. Would you be able to further describe it, or is it solved?

It is solved.

For clarity, I’ll describe what happened in the order it happened.

  • I followed the instructions as written for lines 1-3 and everything was correct on the first try.
  • On line 4 I originally wrote:

print((6 ** 2) * 6)

  • This is incorrect
  • I received the message:

6 ** 3 will yield 6 6x6 quilts, but all 6 people are asking for 6 quilts

  • In the output, the answer was 216
  • I corrected my answer by writing:

print(6 ** 4)

  • However, the answer was still 216 and I received the same error message.
  • I logged out of Codeacademy and quit Google Chrome.
  • I reopened Chrome, logged back in and went to the exercise.
  • Everything worked fine.