Exercise 6 - Supporting Content, Step 2 Fails - Invalid character


#1


https://www.codecademy.com/courses/make-a-website/lessons/bootstrap/exercises/supporting-content?action=resume


In step 1 you are instructed to add the section class of container below the jumbotron section. When I add the code and click run I receive both a green check mark as though I was successful, but I also receive an "Invalid character" message in the middle code box. When I enter the code in step two - I receive the dreaded red X when I click run and cannot proceed. The "Invalid character" message is still in the middle code box. Attached is the entire code segment from the exercise.
Please advise.


<!DOCTYPE html>
<html>
<head>
  <title>Skillfair</title>
  <meta charset="utf-8"/>
  <link rel="stylesheet" href="https://maxcdn.bootstrapcdn.com/bootstrap/3.3.6/css/bootstrap.min.css" integrity="sha384-1q8mTJOASx8j1Au+a5WDVnPi2lkFfwwEAa8hDDdjZlpLegxhjVME1fgjWPGmkzs7" crossorigin="anonymous">
  <link href='https://fonts.googleapis.com/css?family=Roboto:300,400,700' rel='stylesheet' type='text/css'>
  <link rel="stylesheet" type="text/css" href="main.css">
</head>
<body>
  <header class="container">
    <div class="row">
      <h1 class="col-sm-4">Skillfair</h1>
      <nav class="col-sm-8 text-right">
        <p>newest</p>
        <p>catalogue</p>
        <p>contact</p>
      </nav>
    </div>
  </header>
  <section class="jumbotron">
    <div class="container">
      <div class="row text-center">
        <h2>Homemade Goods</h2>
        <h3>This Year's Best</h3>
        <a class="btn btn-primary" href="#" role="button">See all</a>
      </div>
    </div>
  </section>
  <section class="container">
    <div class="row">
    </div>
    <div class="row">
    </div>
  </section>

</body>
</html>


#2

I have the same problem.


#3

I don't see a problem with the markup. Be sure not to include ... shown in the instructions. That is just a visual placeholder which if it is in the code needs to be commented.

    // ...

#4

Me too.:unamused: I have the same problem.


#5

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.