Exercise 3 is broken


#1

I've tried it in two different browsers now but it seems exercise 3 is broken, whenever I click "Run" I just get an endless spinning wheel.


#2

Same as me, I tried restarting, re writing the code and everything.


#3

The same with me, I've tried the same but nothing works :confused:


#4

same here and I have sent lots of message to admin


#5

cant use this endless wheel ive tried copying the code and pasting it i was thinking about downloading another browser but if you have then whats the point.


#6

same here...entered the code in all possible ways with no apparent result but endless spinning wheel
:-((


#7

Yep, it's broken. Looking to work through SQL today and this is basically the first step. haha


#8

Guys for some god-forsaken reason if you take the ; at the end of the code it works, so you can try that if you want to get through this course today.


#9

The same! :pensive:
How can I change this?


#10

remove ; at the end of line and it will work


#11

I was able to get mine to work by taking the semicolon out but then the next step it won't let me proceed if I leave out the semicolon. So when I put it back, the endless wheel returns :frowning:


#12

Were you able to get through the next step though? It requires you to use the semicolon but then doesn't load.


#13

Yeah after I took the semicolon out it finished the exercise and let me through to the next one. I've since finished the entire SQL course


#14

Trying this now and it doesn't' work. If I take it out I get Error: incomplete SQL: CREATE TABLE celebs ( id INTEGER, name TEXT, age INTEGER ) If I end it with the semicolon I get this Error: near line 1: table celebs already exists.


#15

A post was split to a new topic: 3. Need some help


#16

I'm seeing the same thing even with the silly convention of capitals:

CREATE TABLE celebs (id INTEGER, name TEXT, age INTEGER);

returns a table already exists errawr. This is because the table already exists in the schema that the exercise is using. If you try the following code it will work:

drop table celebs;
create table celebs (id integer, name text, age integer);

Basically drop the table from the schema then re-create it immediately after and it will pass you.


#17

Yea, I dropped it and then recreated it and it worked. Thanks. I'm about 3 yrs removed from SQL


#18

Same here. Removing the semicolon only helps sometimes. Refreshing the page sometimes helps (F5 or clicking reload).


#19

CREATE TABLE table_name (
column_1 data_type,
column_2 data_type,
column_3 data_type
);
CREATE TABLE celebs (id INTEGER, name TEXT, age INTEGER);

put it this way


#20

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.