Exercise 10: Can't import 'date' module


#1

Hello all, I'm having trouble with Exercise 10.


Edit: Closing browser and trying again fixed the issue.


I'm trying to import the Date module, but I get the error message:

cannot load such file -- date


Here's my code:

require 'date'

puts Date.today


Here's a screenshot of exactly what my situation looks like:


I feel pretty confident that I've followed the instructions exactly, and I've run out of ideas to try. Any help would be appreciated!

Edit: Closing browser and trying again fixed the issue.


#2

Same code, same issue. Looked through the old forums and found no good answer. All of the code that worked properly is identical to what is posted here.


#3

Hey Jason, I don't know if you got a notification for my edit, but restarting my browser may have been what fixed the issue for me. If that doesn't work let me know and I'll try to look over everything I did before it got fixed.


#4

Well this is one way to pass I guess :rofl:

I am confident the code in the string is correct (using the lowercase require) so nbd but definitely something wrong with this exercise:


#5

Just had the same issue and had to "get code" only for the browser to show the exact same code I had before. Maybe it is a bug..


#6

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.