ExecJS::RuntimeError in Tags#show


#1

Hey guys.

I got stuck at 6.5, where I was prompted "Did you add a link to the destination". I finally got there, apparently at tags#show, when I had <%= d.description %> inside <p>, I wasn't able to advance in that point.

After that, when I had to update the page, I got this error ExecJS::RuntimeError in Tags#show

the rest of the page gives me:

 Showing /home/ccuser/workspace/learn-rails-one-to-many/app/views/layouts/application.html.erb where line #6 raised:


node.js:854
    var cwd = process.cwd();
                      ^
Error: ENOENT, no such file or directory
    at Function.startup.resolveArgv0 (node.js:854:23)
    at startup (node.js:58:13)
    at node.js:945:3

  (in /var/lib/gems/2.0.0/gems/turbolinks-2.4.0/lib/assets/javascripts/turbolinks.js.coffee)

Extracted source (around line #6):

3
4
5
6
7
8
9
          

	

  <head>
    <title>TravelApp</title>
    <%= stylesheet_link_tag    'application', media: 'all', 'data-turbolinks-track' => true %>
    <%= javascript_include_tag 'application', 'data-turbolinks-track' => true %>
    <%= csrf_meta_tags %>
  </head>
  <body>

This didn't prevent me to move on to the next lesson, but at the end of this other lesson I got the same kind of message (actually, the one I put here was from lesson 7).

Any clue how should I check what the problem is?


#2

btw, the line #6 points to <%= javascript_include_tag 'application', 'data-turbolinks-track' => true %>

I tried to dig a little further, updating (bundle update, bundle install) and tried to rerun the server, but I didn't manage to get out of this error.


#3

Hi @diobsb,

Could you please post a link to the exercise you're on and a screenshot of the problem you're seeing? I don't think you should be getting that error.


#4

Here's the link to the lesson: https://www.codecademy.com/en/courses/learn-rails/lessons/one-many/exercises/one-many-show-destination

As I reported earlier, I tried to find the solution to that issue. I don't know if my actions made it worse than before, but I no longer get anything in the browser, I just get a Not Found message. I finally reported this as a bug, through the "report a bug" link.

I tried to redo all the lessons, I had to do a rake db: migrate --force in order to migrate over a db that already existed... Well, I did a plenty of stuff that I don't know if I should have done them.

Here is the print screen in the current situation (I don't have the printscreen from the original error), where you can see the "not found" message, which is the same for all pages (tags; tags\1; destinations etc.):

running rails server didn't change anything.

This problem didn't prevent to me to finish the lessons, I'm currently in the Associations II lessons, which is working fine. But Associations I is still frozen in that state.


#5

@biobsb Not sure what's wrong, sorry :confused:

The page shows up for me. Does it work on other exercises, such as Associations II?


#6

The only one not working is Associations I, all the rest are up and running.

Nevermind. I reported as a bug, let's see if they can find someething useful in order to avoid problems in the future


#7

@diobsb Thanks for reporting it! I don't recall having heard of an issue like this before :confused:


#8

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.