Excersise 1


#1

Perhaps I misunderstood the task. The browser prints “not found” after specified steps done

https://www.codecademy.com/courses/learn-rails/lessons/start/exercises/start-hello-rails?action=resume_content_item

$ $ rails new MySite $ bundle install
create
create  README.rdoc
create  Rakefile
create  config.ru
create  .gitignore
create  Gemfile
create  app
create  app/assets/javascripts/application.js
create  app/assets/stylesheets/application.css
create  app/controllers/application_controller.rb
create  app/helpers/application_helper.rb
create  app/views/layouts/application.html.erb
create  app/assets/images/.keep
create  app/mailers/.keep
create  app/models/.keep
create  app/controllers/concerns/.keep
create  app/models/concerns/.keep
create  bin
create  bin/bundle
create  bin/rails
create  bin/rake
create  config
create  config/routes.rb
create  config/application.rb
create  config/environment.rb
create  config/secrets.yml
create  config/environments
create  config/environments/development.rb
create  config/environments/production.rb
create  config/environments/test.rb
create  config/initializers
create  config/initializers/backtrace_silencers.rb
create  config/initializers/cookies_serializer.rb
create  config/initializers/filter_parameter_logging.rb
create  config/initializers/inflections.rb
create  config/initializers/mime_types.rb
create  config/initializers/session_store.rb
create  config/initializers/wrap_parameters.rb
create  config/locales
create  config/locales/en.yml
create  config/boot.rb
create  config/database.yml
create  db
create  db/seeds.rb
create  lib
create  lib/tasks
create  lib/tasks/.keep
create  lib/assets
create  lib/assets/.keep
create  log
create  log/.keep
create  public
create  public/404.html
create  public/422.html
create  public/500.html
create  public/favicon.ico
create  public/robots.txt
create  test/fixtures
create  test/fixtures/.keep
create  test/controllers
create  test/controllers/.keep
create  test/mailers
create  test/mailers/.keep
create  test/models
create  test/models/.keep
create  test/helpers
create  test/helpers/.keep
create  test/integration
create  test/integration/.keep
create  test/test_helper.rb
create  tmp/cache
create  tmp/cache/assets
create  vendor/assets/javascripts
create  vendor/assets/javascripts/.keep
create  vendor/assets/stylesheets
create  vendor/assets/stylesheets/.keep
$ $ rails server
=> Booting WEBrick
=> Rails 4.1.1 application starting in development on http://localhost:8000
=> Run `rails server -h` for more startup options
=> Ctrl-C to shutdown server
[2015-03-17 18:46:05] INFO  WEBrick 1.3.1
[2015-03-17 18:46:05] INFO  ruby 2.0.0 (2013-11-22) [x86_64-darwin13.1.0]
[2015-03-17 18:46:05] INFO  WEBrick::HTTPServer#start: pid=82666 port=8000
$


Screenshot_3

step 2 alternative - command “$ bundle install” not recognised


#2

Hi @karolis12345,

When typing a command in the terminal, leave out the dollar sign ($). It’s merely used to indicate the beginning of a terminal prompt, not actually meant to be typed. Try running bundle install in the terminal without typing a dollar sign at the beginning, and see if it works then.


#3

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.