Error with bash profile

when i was doing this course on pipenv (, when following the instructions at six minutes i think i went wrong because my bash profile now shows the following error:

-bash: dirname: command not found

-bash: dirname: command not found

-bash: dirname: command not found

-bash: dirname: command not found

The default interactive shell is now zsh.

To update your account to use zsh, please run chsh -s /bin/zsh.

For more details, please visit

I went down this rabbit hole recently.

Codecademy has a shell profile set up guide in tips and resources Setting Up Your Command Line with a video by Farish @71kash (which hopefully you encountered before the pipenv review). Their lesson supplement is specifically a bash set up because the lessons are in bash, which can only help you so far if you’re eager to run a thorough shell set up on zsh with efficient control of file system navigation and clean pip/env/version functionality.

Here are some external resources that helped me:

Good to note that these are more or less approaches to the same thing – pip/env configs with zsh setup.

I think, for Mac users, Briegel’s blog and book really help explain what running chsh -s /bin/zsh does to your machine in order to then inform how you wish to shell script on a 2020 Mac/Terminal in general.

1 Like

Also, with the release of Catalina, zsh is the default. If you have updated it might break things. Your bash shell might be recoverable with chsh -s /bin/bash . Overall, the commands are the same, you gain some additional features with zsh. I have seen some problems with the terminal though after a Catalina update.

1 Like

Hi! please help.

I Installed Git Bash. tried to create a test directory but I had the following error:

Yohanna@Yohanna-HP MINGW64 /
$ ls
LICENSE.txt cmd/ git-bash.exe* proc/ unins000.exe*
ReleaseNotes.html dev/ git-cmd.exe* tmp/ unins000.msg
bin/ etc/ mingw64/ unins000.dat usr/

Yohanna@Yohanna-HP MINGW64 /
$ mkdir test
mkdir: cannot create directory ‘test’: Permission denied

Yohanna@Yohanna-HP MINGW64 /

It looks like you’re in the root directory “/”. Permissions here are limited and you don’t really want to be working here anyway.

Navigate to your user home directory and start working there instead. This would typically be under c/Users/username where username is replace with your actual username. Use ls and cd to navigate if you’re uncertain. Typically the command cd ~ would shift you to the correct directory, echo $HOME should also fire the home directory to stdout if you wanted to check.

Please try and ensure your reply matches the content of the thread in future as this isn’t strictly related to pipenv, zsh or the bash profile.


Hello…I appreciate your further assistance on this:

  1. I’ve updated the “Start in” folder by choosing “Properties” from the Git Bash Shortcut icon on my Desktop
    a. I changed the “Start in” on the “Shortcut” tab to “C:\Users’my name”. This was saved.
    b. Although, on the “General” tab, I am still seeing “Location” as “C:\Users\Public\Desktop”

  2. Going back to trying to run the test codes from the “Command Line Interface Setup” outlined in CA course, nothing is still working, e.g.

    • I type in, “1s”, I am returned, “bash: 1s: Command not found”
    • I type in, “mkdir test” I am return, “mkdir: cannot create directory ‘test’: file exists”

In other words, still, nothing is working for me on Git Bash.

Any thoughts on what I am doing wrong as CA Support refuses to provide any type of support on their own course.

Thank you!

If there’s something you’re stuck on then you can always try the community forums or discord, if nothing else there’s the history of others coming unstuck and (hopefully) getting solutions. If you can’t find one that suits then check the following guidance and create your own query- How to ask good questions (and get good answers)

I’ve not tried fiddling with gitbash for while and I’m not on windows at the moment so I can’t help you with part1 right now (what is it you are trying to do there?).

As for part 2 the command is lowercase L followed by lowercase S (it’s just a contraction of list). So use ls, not the digit 1 followed by s. For the second issue mkdir won’t overwrite an existing directory, it appears that there is already a directory called “test” in your current working directory. Hopefully ls will show it to you.

Thank you for the response!

  • Having changed the “Start In” in the GB shortcut properties on my desktop did the trick.
  • Gotta brush up on my “1’s” and “l’s”…haha

Take it easy.

1 Like

you are life saver, thanks