Error when running "npx create-react-app myfirstreactapp"

When I try to run this command in terminal: “npx create-react-app myfirstreactapp” I just end up with a load of permission errors, any idea what I need to do to make it run?

errors returner:

Creating a new React app in C:\cygwin64\home\esteb\Projects\MyFirstReactApp\myfirstreactapp.

Installing packages. This might take a couple of minutes.
Installing react, react-dom, and react-scripts with cra-template…

npm ERR! code E404
npm ERR! 404 Not Found - GET - not_found
npm ERR! 404
npm ERR! 404 ‘lodash.sortby@’ is not in this registry.
npm ERR! 404
npm ERR! 404 Note that you can also install from a
npm ERR! 404 tarball, folder, http url, or git url.

npm ERR! A complete log of this run can be found in:
npm ERR! C:\path

Aborting installation.
npm install --no-audit --save --save-exact --loglevel error react react-dom react-scripts cra-template has failed.

Deleting generated file… node_modules
Deleting generated file… package.json
Deleting myfirstreactapp/ from C:\path


What does the complete log say?

1 Like

I’d send it to you but fortunately I was able to resolve the issue and I am now able to create React apps! Someone suggested I run “$ npm config set registry” and that fixed it. Ever since then, I’ve been able to create apps!