ERROR setting up boilerplate app using create-react-app

Creating a new React app in G:\My Drive\Coding\Projects\myfirstreactapp.

Installing packages. This might take a couple of minutes.
Installing react, react-dom, and react-scripts with cra-template…

npm ERR! code ENOTDIR
npm ERR! syscall mkdir
npm ERR! path G:\My Drive\Coding\Projects\myfirstreactapp\node_modules\webpack\node_modules
npm ERR! errno -4052
npm ERR! ENOTDIR: not a directory, mkdir ‘G:\My Drive\Coding\Projects\myfirstreactapp\node_modules\webpack\node_modules’

npm ERR! A complete log of this run can be found in:
npm ERR! C:\Users\Isaac\AppData\Local\npm-cache_logs\2022-03-01T19_51_46_288Z-debug-0.log

Aborting installation.
npm install --no-audit --save --save-exact --loglevel error react react-dom react-scripts cra-template has failed.

Deleting generated file… package.json
Deleting myfirstreactapp/ from G:\My Drive\Coding\Projects
Done.

This is happening on both my desktop and laptop. Any help would be greatly appreciated!

That’s because you’re trying to install it in your Google Drive folder. I had the exact same issue, and when I tried to install in regular folder, it worked!