Error: near line 1: no such table: celebs

I tried writing the instructed code:

SELECT * FROM celebs;

But it just comes back with:

Error: near line 1: no such table: celebs

Tried it in chrome, Firefox and IE and get the same error. Any suggestions?

1 Like

Im preety sure your suppose to create the table celebs then… Try this?

CREATE TABLE celebs
(
column_name1 data_type(size)
);

Fill column with your needs… Hope this works… :wink:

1 Like

I’m sure that will work but the instructions simply state to type in SELECT * FROM celebs; and click run. The next screen says, “Nice work. In one line of code, you returned information from a relational database” which implies it should have returned a result without having to add additional code.

Am I right in saying I shouldn’t be require augmenting the code to get it to work? in which case is the coarse bugged at lesson 1?!

1 Like

Wow @identityflux i actually faced this bug!

So yes, there is a high chance this lesson is bugged. But did you pass the lesson? if you didnt try to do the same exact code i did on the topic i posted… then it will create the table celebs…

Reset the lesson, copied to text again (which I’d already done) and it worked. Restarting it seemed to clear the issue. :confounded:

Thanks for the info.

how to reset the lesson?

https://discuss.codecademy.com/t/how-can-i-reset-my-course-or-exercise-progress/29812

I’m currently having this same problem too. I’ve been trying to reset but to no avail. Any other suggestions please?