Error 403 when trying to post in forum

I can’t post replies in the forum, in Brave browser I get the message “403 error” and in Firefox I get “403 forbidden”.

I don’t know if it’s relevant but I use a VPN since I’m in China.

The problem seems to come and go, a couple of days ago I get the error but was able to post eventually. Today I’ve tried to post a reply several times but have not been able to

1 Like

Let’s see if I can reply here

Yep, that seems to work, but i still can’t post here: Jammming - after authentication, search is not working - #5 by script0526291217

I’ve had the problem in other posts too.

This happened to me with one topic, too. I don’t use a VPN and I am not located in China. Curious what might be the reason for this.

1 Like

I have had it happen when I tried replying to a couple of threads. I don’t use a VPN either. I may have been drafting a reply and then left the thread. After hibernating & returning and trying to post the draft and/or a fresh post, it gave me the 403 forbidden error. Waiting or restarting the browser didn’t help. The threads weren’t private, but for some reason, it locked me out from those threads.


I am having trouble posting my code to the forum. I have done this in the past with no issues, now I get a 403 error. can someone tell whats going on? (thats if this post work!)

Same problem for me. I am trying to post to the forum but I’m getting a 403 error.

1 Like

Me too :confused:
I’m trying to post a reply here with code:

But when I send the reply, a 403 error warning is shown.
I can only post without code…

Can someone from the administrators help, please?

I got the 403 forbidden error again on another thread. Changing browser, reloading page etc. didn’t help. But eventually, I did stumble upon something. Perhaps it may offer some clues.

When I tried to submit a post which had script tags in one of the code snippets (nested in the pairs of three backticks), a “drafts offline” message appeared at the bottom of the editor and a 403 Forbidden error alert prevented submission of the post. When I edited out the code snippet with the script tags, the message went away and I was able to submit the post.

This wasn’t allowed:

This worked:

1 Like

@codecademy could you please look into this?
The issue still persists. And it seems to be related to code being posted as @mtrtmk suggested. But it is not limited to script tags. It also happens with code that does not contain tags.

1 Like

Hi all!

Thanks for flagging this issue. We’re looking into it and hope to have it resolved soon.


Hi @codecademy,

is this error still investigated? It makes the forum difficult to use, that some code cannot be posted. I just tried to post a code snippet and got the error. These two lines in the code are responsible:

A “403 Forbidden” error may occur due to various reasons: insufficient permissions, lacking appropriate resource access, or misconfigured security settings. The server’s settings could be wrongly configured, hindering access, while corrupted server files might also trigger this error. Additionally, during a DDoS attack, resource access could be temporarily blocked to safeguard against the attack.

To address a “403 Forbidden” error, consider these steps: Verify your permissions for resource access. Ensure the server’s security settings aren’t obstructing your access. Temporarily disable third-party browser extensions to eliminate potential conflicts. Reboot your device as a simple troubleshooting step. If issues persist, contacting the website administrator might be necessary after exhausting prior measures.