Editor Role I step 1 not working


#1



I have having a problem getting past the first step of Editor Role I. I have tried multiple different spacing and indentations, but nothing seems to work. Here is my code:

class User < ActiveRecord::Base
has_secure_password

def editor? 
	self.role == 'editor' 
end

end

https://www.codecademy.com/courses/rails-auth/lessons/authorization/exercises/authorization-editor-role-i?action=lesson_resume


My error message:
Oops! The test returned an error. Maybe you have a syntax error, or a typo. See full error.
/home/ccuser/.gem/ruby/2.3.0/gems/activesupport-4.1.1/lib/active_support/values/time_zone.rb:285: warning: circular argument reference - now


#2

Hi @carterz17,

It looks to me like this is a problem with Codecademy, not your code. Please report it through the form below the instructions on the left, then try one of the solutions found by other forum members:

https://discuss.codecademy.com/t/tzinfo-data-error/85895?u=zystvan
https://discuss.codecademy.com/t/pages-controller-rb-not-in-folder/84291/12?u=zystvan


#3

Unfortunately, neither methods worked. I have reported the issue to codeacademy. Thanks for the help, anyways!


#4

@carterz17 Sorry to hear that. Please let me know if you find a solution, there are several other learners with the same problem right now.


#5

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.