Does not take code - lesson 1 nano


#1

When I type "Hello, I am nano." ^O and press enter like it says to do in the instructions, it just goes to the next line without registering that I did anything, i've tried using other commands but it still doesn't take it. Can anyone help me with this?


#2

Are you writing any name to the file? - Remember you should press Ctrl + O writing the echo to save the file. Give it a filename and then press enter.


#3

I gave the file a name - but it did not solve the problem, I appreciate the answer, though. Any other suggestions, I would really like to finish this exercise.


#4

I semmed to have a simmilar problem with this exercise, the thing is, that you have to write the instructions shown in the instruction pannel. There it says you have to write nano '~/.bash_profile' - notice that this is a whole word. After this, Write the text into the nano text editor, "Hello, Nano" or whatever you want, press Ctrl + O, and you shouldn't have to add a name to the profile cause you already created one: 'bash_profile'. Now press enter and exit the nano, clear, and finally you should be able to continue with the excersice. Hope this result usefull to you.


#5

I just passed this
First type in nano hello.txt
then "Hello, I am nano."
then while pressing on Ctrl on your keyboard press on the Letter O
Then press enter
Press on Ctrl on your keyboard while pressing on the letter X
Type clear
Done!


#6

Oh, I didnt know that! Thank you so much, this solved the problem.


#7

Glad I can help! :slight_smile:


#8

Big help. Thank you very much.