Does EcmaScript 1 works in the latest version of browsers?

Let’s say I wrote my Javascript code following the ECMAScript first edition, would it works with the latest version of browsers?