<!DOCTYPE> tag


#1

This tag is broken. What should I do? I put it in correctly, but it won't let me move on.


#2

First show us your code. :smile:

Then we'll look at it.

Show us your code using the backticks that are on top of the tab key, like this:

```
<!DOCTYPE html>
```

:smiley:


#3


<!DOCTYPE>
<html>
<head> <title> Hamiltony </title> </head>
<body> HAMILTONY: THE FAN BLOG FOR HAMILTON: AN AMERICAN MUSICAL </body> </html>

Yeah, my website is kind of nerdy lol. I just don't know why the doctype thing isn't working. I've probably tried 20 times.


#4

Hey @sjbneedsatony,

I believe it's <!DOCTYPE html>....


#5


<!DOCTYPE html>

I tried this and it didn't work... Am I doing this wrong?


#6

@sjbneedsatony Use <!DOCTYPE html>, then try refreshing and switching browsers. If that's not working, please let us know & I'll take a closer look to see if I and @ragezapper can help you find the problem :)


#7

@zystvan and @ragezapper Before we get any further, @sjbneedsatony i will need you to take a screen shot and post it here. Thankyou.


#8


#9

You also need a <html> right after your <!DOCTYPE html>. :smile:


#10

@sjbneedsatony! Your problem is to put your Html Tag. So between the DOCTYPE and Body tag put in the <html> tag you forgot to put it! Hope it works! I

Speedy ragezapper !


#11


I thought I fixed that but I guess not?


#12

Haha LOL. I just find mistakes faster. :sunglasses: Lol jk I never knew you were on.


#13

You took away a > when you added the <html>. :smile:

You need to add a > now after your <!DOCTYPE html>.


#14

You forgot to close your DOCTYPE with the > . I win this time @ragezapper!!!

Seriously... your to fast...


#15

LOL Haha :sunglasses: :laughing:


#16


Oh my goodness I'm sorry I keep messing up but I really think I got it this time! What did I do wrong? It says the problem is with doctype but I don't see how... Thank y'all for being so patient!


#17

<!DOCTYPE html>
<html>

#18

It's <!DOCTYPE html> and <html>.... they're separate things. :smiley:

Exactly what @darrens12 has shown :smile:


#19

I finally got it! Thanks so much


#20

I had the same problem. Though I really don't understand why this is an error. For all I know !doctype doesn't have to be uppercase, it works fine even if it's all lowercase, so does anyone know why the lesson doesn't accept it?