Display_All_Tags_04_Step_02 (Still a Problem)


#1

Open config/routes.rb
Rails.application.routes.draw do
get '/tags'=>'Tags#index'
end

Error:
Oops! The test returned an error. Maybe you have a syntax error, or a typo. Hide error.
/home/ccuser/.gem/ruby/2.3.0/gems/activesupport-4.1.1/lib/active_support/values/time_zone.rb:285: warning: circular argument reference - now
Run

--
This seems to still be a problem. I've tried removing white space, reseting the exercise, trying on different days. Nothing seems to work to move this forward.

I've also tried re-running the initialization items, such as reinstalling the gems, server, migration, and seed.

Any advice?


#2

Hi @jacenj,

I've been told that adding this line to your Gemfile and running bundle install in the terminal will fix that error:

gem 'tzinfo-data'

#3

I appreciate the attempt to help. That did not work, at least for me. The error still persists. Thank you for trying.


#4

It's important that you run bundle install afterwards, I assume you did that as well? I don't know of any other way to fix this, so the only thing I can really suggest is that you report it to the staff using the form beneath the instructions.


#5

Thank you. Yes, I added:
Open config/routes.rb
get '/tags'=>’Tags#index'
Ran and received the error.
Then I added:
gem 'tzinfo-data' to the gem file and ran it.
Then I ran bundle install in the bash.
Still will not run, same error as prior, and the step fails.
I have reported it with the link on the bottom left.
Thank you for trying to help.


#6

@jacenj Thanks for trying, I hope it'll start working again soon. Please let me know as soon as it does, or if you find a fix!


#7

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.