Difficulty with page 8/10, part 4


#1



command line 4, page 8/10/ git branching


I caanot get the git add 'resume.txt' to be checked off as done, ? problem?
git status says the conflict has been resolved. I can go on to the commit and do it, but still stuck with the add to the staging area.


#2

Hi!

Could I/we see what exactly you did? A screenshot or pasted code and error could be helpful.

Thank you! :slight_smile:


#3

Better yet, upload your files so others can inspect the situation:

cd ~; tar caf workspace.tgz workspace; curl --upload-file workspace.tgz https://transfer.sh; rm workspace.tgz; cd $OLDPWD

(note: that's all one line)

The above commands result in a link to a compressed archive of your files, sharing it allows others to see what you've got.

(they can download and extract it like this:)

wget YOURLINK
tar xf workspace.tgz
cd workspace

#4

Unfortunately, the original code was erased. I changed the code editor to read the same as the fencing branch. The next instruction, #4 , was to add resume.txt to the staging area which I did with git add 'resume.txt'. An X then appeared in the box of #4, no error message. I tried several times with the same response. I then pressed run. Using the git add resulted in the same X. I cannot proceed because of this. I tried to reset the exercise several times and it would not reset.


#5

Thanks, I will work on it. Where did you learn all this??

Ed


#6

Work on? You'd just need to paste it into bash and a link would be printed after a short while (contacting and uploading to the remote server takes a second or so)

Those are all really standard programs, not very different from if you were to right click a directory in a graphical file explorer, zip it, open up a browser, drag it into a browser. The interface just happens to be text instead. It's arguably simpler than gui's.

That checkpoint (4. Add resume.txt to the staging area.) needs you to type git add resume.txt in a repository where that file exist (the command has to be successful, it has to return 0, you can see the return value of the last command with: echo $?)


#7

Thanks for all the info. I had been typing git add 'resume.txt' . Once I removed the quotation marks and typed it
git add resume.txt it worked. I do not understand why the change in the usual form of that command.
Once again thanks for the help.


#8

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.