Deploy your website to GitHub pages - Cannot deploy site due to mistake


#1


https://www.codecademy.com/en/courses/deploy-a-website/lessons/github-pages/exercises/add-remote?action=lesson_resume



I have a problem. I have completed the "Deploy your website to GitHub pages" section with the wrong https address, i have tried to remove it from origin but i couldn't it just returns "error: not a github repository".
Then i tried to redo the whole exercise but it didn't help. What do I do? Please help.


#2

"error: not a github repository"
You'd have to navigate to the repository first


#3

And what do i do when i am in it? I dobt find your reply helpful, sorry. Could you explain a bit?


#4

If you try to sit down and there is no chair, you get an error message: error, no chair
You move to a chair.
Then you try sitting again.

Try again.


#5

Do you mean to also ask how to remove a remote?
If you type git help remote then you will be presented with a manual for that command, at the very beginning it lists different valid ways to invoke it:

GIT-REMOTE(1)                     Git Manual                     GIT-REMOTE(1)

NAME
       git-remote - Manage set of tracked repositories

SYNOPSIS
       git remote [-v | --verbose]
       git remote add [-t <branch>] [-m <master>] [-f] [--[no-]tags] [--mirror=<fetch|push>] <name> <url>
       git remote rename <old> <new>
       git remote remove <name>
       git remote set-head <name> (-a | --auto | -d | --delete | <branch>)
       git remote set-branches [--add] <name> <branch>...
       git remote get-url [--push] [--all] <name>
       git remote set-url [--push] <name> <newurl> [<oldurl>]
       git remote set-url --add [--push] <name> <newurl>
       git remote set-url --delete [--push] <name> <url>
       git remote [-v | --verbose] show [-n] <name>...
       git remote prune [-n | --dry-run] <name>...
       git remote [-v | --verbose] update [-p | --prune] [(<group> | <remote>)...]

And there's a bit more detail further down:

       remove, rm
           Remove the remote named <name>. All remote-tracking branches and
           configuration settings for the remote are removed.

#6

Thanks I'll try that soon today (when i have time)


#7

Thank you! I have figured it out.


#8

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.