"Deploy site with GitHub" tutorial not working

Hi there. I am starting the full stack developer path, and am currently on the “Deploy site with GitHub Pages” tutorial. I have followed the creation of the repo and the index.html file, but get a 404 when I try to go to view the site that should have been created at ivo.github.io.

I have used https and http, and made sure that EVERYTHING was lower case, but have no idea what to do to move forward. I have made it as far as the section called “Viewing your website”. any help that you guys can provide would be HUGELY appreciated.

here is a link to the article that I am trying to follow for reference: https://www.codecademy.com/paths/full-stack-engineer-career-path/tracks/fscp-22-deploying-websites/modules/wdcp-22-deploy-a-site-with-github-pages/articles/creating-a-website-on-github-pages

is your repo linked to the webpage?
And, you used https?



I did figure out that it WAS being deployed, but the address it is going to is https://ivo-blaze.github.io/ivo.github.io/ I have zero clue how to fix that.

that doesn’t work.
I amended the address in the search bar to, https://ivo-blaze.github.io

that works.

I had renamed the repo to ivo-blaze.github.io.

I am still not clear as to why that repo name worked, but ivo.github.io didn’t.

Hi there,

I am having the exact same issue, not sure what I am doing wrong. its just not loading. I see you renamed your repository and that worked?

I figured it out. my Index.html was with a capital “I” and not a lowercase “i”. dafuq.