Deep Learning - Regression Challenge Project Help Needed


I’m getting an error when I’m fitting the model saying it’s the “nonetype” object is not callable.

What am I doing wrong here?

When I try to view the file, it says I need permission to view it.

Sorry, try again. I’ve opened up the link.

Hello! I’ve invited @lisalisaj to this topic, as I don’t really have much knowledge in this area. Where is the error occurring (what line, etc)?


Hello! I’m not familiar with regression models or neural networks (yet), but can try to help out.

Because you used the upload widget, I can’t run any of the cells b/c I don’t have access to the csv file (b/c it’s local to your machine). I see the error at the bottom of the notebook, but I don’t see what line of your code it’s in reference to.

It’s something around this line:

return self._stateless_fn(*args, **kwds)  # pylint: disable=not-callable
    856     elif self._stateful_fn is not None:

I found this on StackOverflow, did you see this as well?

This also might be helpful for sharing Colab files:

1 Like

So I changed the data file from local to github and for some reason the error disappeared. Problem solved. :slight_smile: The sharing colab files seemd to have somehow solved it. Not sure why though. Thanks so much.

1 Like