Custom Domain/URL for full stack app

Hello all,

I’m working on deploying a full-stack app on a service (so far using EvenNode, but still in free trial so can switch to get what I need). I have it all up and running, but I want to use a custom domain. Right now I have a domain mySite.com which redirects to mySite.us-2.evennode.com. I would like to have the URL just be mySite.com (and mySite.com/about, etc). Any tips on what to learn to accomplish this?

Additionally, I’m getting double slashes at the end of the URL. (mySite.us-2.evennode.com//) and I’m not sure why, but hopefully that problem will be solved by solving the first problem.

It is a problem with your DNS setup. Your A record should point to EvenNodes server and your cname defines the name of the site (ie mySite.com). Maybe look at this article for some additional details?
DNS Records

1 Like

Hmm I couldn’t find an ip anywhere on EvenNode. Their 20-words-long doc on custom domains is not much help, haha. Haven’t heard back from their support team either. If i can’t find anything maybe I’ll try out a different service. But thank you for clarifying, I think I understand now what I need!

I’ve tried with both EvenNode and now I’m on Heroku. It looks like the problem is that I’m using Google Domains. As described below, Google Domains only allows A records for root domains.

From Heroku docs:


Configuring DNS for root domains

Configuring your DNS provider for a root domain is similar to configuring a DNS provider for a subdomain. However, whereas with subdomains the type of record to configure is always a CNAME, with root domains the type of record depends on the DNS provider:

Some DNS providers will only offer A records for root domains. Unfortunately, A records will not suffice for pointing your root domains to Heroku because they require a static IP. These records have serious availability implications when used in environments such as on-premise data-centers, cloud infrastructure services, and platforms like Heroku. Since Heroku uses dynamic IP addresses, it’s necessary to use a CNAME-like record (often referred to as ALIAS or ANAME records) so that you can point your root domain to another domain.

Have you tried digital ocean? Maybe their hosting would be better for your needs then?

I have actually been thinking about setting up on there, but I’m not sure yet. As far as I know they aren’t a domain registrar? So I believe I would still have the same issue with the root domain A record.

I think once I am able I will transfer the domain to another registrar like Namecheap and it should work then. :slight_smile:

Let me know how it works out. I have only set up a dozen or so domains, so I haven’t run into the issue you are having unfortunately. Good luck!

1 Like

I figured it out. Google Domains doesn’t allow CNAME for root domain, but they do allow custom name servers. I signed up with CloudFlare (free tier) and was able to reroute through them.

Basically I cleared all the A and AAAA records that showed up with DNS search, and put in a CNAME (my.app → myapp.service-domain.com) as the only record. CloudFlare supports CNAME flattening, which (as I understand it) converts myapp.service-domain.com to an IP which then stands as the A record. CloudFlare provides the urls for their name servers to provide to Google Domains under custom name servers. It was all fairly easy to do. After the 60 days waiting period I’ll probably transfer my domain from Google to CloudFlare.

Now when I go to my.app, I access the app hosted at myapp.service-domain.com but the URL still shows my.app. Success!

ETA: Also realized CloudFlare provides free SSL certificate, so now my site can also use https. Bonus!

1 Like