Cursor location in accordance to the text on screen are not equal


#1


https://www.codecademy.com/courses/introduction-to-python-6WeG3/1/2?curriculum_id=4f89dab3d788890003000096#


Browser or font set causing trouble?


I expect the (text)cursor to move in between the characters, not jump random number of lines.


I dont know if its my browser or the font set I have. Im on arch linux using google chrome from the AUR, though firefox from the standard repos didnt work either. 

This is particularly frustrating with this exercise cuz I have no idea how many lines this cursor is jumping. It seems the size of the spaces and the size of the text are not the same. Why is this setup in a way that text is not directly associated with the placement of the cursor and viceversa? I've never seen text input act like and that seems to be an especially BAD way to do text/code input for a language that values its white space. 

any one know how to fix this?


#2

I have heard of this happening every now and then but I don't recall if it was ever solved.

I would first suggest trying a different web browser. If that doesn't work, could you tell us:

  • your operating system
  • the web browser with the problem

#3

If you read my entire post you'd already have those two answers, so nice way to start that off..

Im certain it was related to font type I was using and/or missing. I've since tried in windows and other OS's and works fine there. Still silly its built that way to begin with but whatever. mark as solved, or dont because you probably wont read all of this anyway.


#4

Hello,

I have a same problem. Cursor is running forward of a text - and the difference doubles by 1 symbol entered.

Giorgi