Ctrl + enter on Window 10 is not functioning

Hi there,

since yesterday I have trouble to use the ctrl+enter key stroke as it won’t log/run the value/function?
Does anyone face the similar problem?

Kind regards

1 Like

Hi there, welcome to the forums!

On some of the exercises in some courses, the code is not automatically run when you click the “Save” button (CTRL + Enter).

These exercises have an interactive terminal in the right-hand side of the learning environment, and usually there is an instruction advising you of the correct command to run what you’ve created.

Without a link to the exercise, though, I can’t say for sure that this is your problem. :slight_smile:


Also for me on Mac not working (cmd + Enter), it worked well before yesterday even in the same course.
I am doing Introduction to Javascript: https://www.codecademy.com/courses/introduction-to-javascript/projects/kelvin-weather-javascript

Could you help?


it was the Scope Lesson https://www.codecademy.com/courses/introduction-to-javascript/lessons/scope/exercises/block-scope that I can’t use the button Ctrl + enter anymore, but it was still working on last week.

Hmm… OK.

Do any of the steps below fix this for you:

Also, if you have any tracking/cookie blockers or similar enabled whilst you’re learning on Codecademy, can you please disable them (temporarily) and see if that fixes it?

Thanks. :slight_smile:

Hello :slight_smile:

Codecademy is currently rolling out a major change in the exercise interface. The editor used in the exercises is now powered by the Monako editor that is also available in one of the most popular code editors (Visual Studio Code). This will allow Codecademy engineers to enable users with editor customizations options, more robust and friendly environment and experience closely resembling working with a real code editor.

This is a major change and some problems happen. I can only assure you that this is a temporary situation and every bug report will be considered.

We greatly appreciate you taking the time to let us know that keyboard shortcuts do not work correctly. I will pass this on to Codecademy engineers and I will inform you back as soon as I get any reply.

Thank you very much! :slight_smile:


Oh, I forgot to mention that there is a workaround!

This problem occurs only if the editor is in focus. If you prefer to navigate through Codecademy lessons only using a keyboard (like I do) then you can use ctrl + m shortcut to toggle option tab key moves focus. This will allow you to use tab key to move to the next element (like in normal situation) and then ctrl + enter will trigger “run”.

It’s not super comfortable, but still much faster than using a mouse :slight_smile:

1 Like


thank you so much for your information. Please let me know if there is any update regarding the missing keyboard shortcut.

Thank you!

I have tried the methods incl. temporarily disable the adblock, but the ctrl + enter is still not functioning.


The troubleshooting link I gave you doesn’t apply here, as it’s not really a bug.

@factoradic’s post above explains why the shortcuts aren’t working. :slight_smile:

@leongfongchoo0556808 @cam.albuquer this problem should be now resolved.

Thank you again for bringing this to our attention.