Creating a React app

https://www.codecademy.com/paths/web-development/tracks/front-end-applications-with-react/modules/react-development-setup-and-ravenous-part-1/articles/how-to-create-a-react-app

Hello, I need help with this lesson on creating a React app.
I have followed the instructions and entered in the git bash terminal:
npm create-react-app my-app

Thereafter, it proceeded to create but it came up with only a package.json and a package-lock.json

This is what was in package.json:
{

“name”: “my-app”,

“version”: “0.1.0”,

“private”: true,

“dependencies”: {

"cra-template": "1.0.3",

"react": "16.13.1",

"react-dom": "16.13.1",

"react-scripts": "3.4.1"

}

}

Thereafter, I tried entering the command: npm start

But it stated that the script for start was not available.
Please help!!

Thanks

npm is a package manager, for installing packages. Not running them. Installing react globally also isn’t the recommend way to go.

I would recommend following the steps from the official documentation:

https://reactjs.org/docs/create-a-new-react-app.html

and use npx. Always check tutorials/blog against official release documentation, blogs and tutorials might become outdated.

Thanks!
However, I have searched for many solutions on the internet and have tried several solutions that were given. I initially did a global installation but have since uninstalled. I even went as far as to reinstall node.js.
Thereafter i followed the steps in the link you have provided:
npx create-react-app my-app
cd my-app
npm start

However, i still got the same results. only a package.json and a package-lock.json
I also tried looking for ‘src’ in package.json, but it was not there.
There were also no scripts present.
Have been trying to solve this issue the past 2 days

Additional info:
This is what is printed on the terminal after ‘npx create-react-app my-app’
Installing packages. This might take a couple of minutes.
Installing react, react-dom, and react-scripts with cra-template…

core-js@2.6.11 postinstall C:\Users\Randy\React\my-app3\node_modules\babel-runtime\node_modules\core-js
node -e “try{require(’./postinstall’)}catch(e){}”

core-js@3.6.5 postinstall C:\Users\Randy\React\my-app3\node_modules\core-js
node -e “try{require(’./postinstall’)}catch(e){}”

core-js-pure@3.6.5 postinstall C:\Users\Randy\React\my-app3\node_modules\core-js-pure
node -e “try{require(’./postinstall’)}catch(e){}”

  • react-scripts@3.4.1
  • react-dom@16.13.1
  • cra-template@1.0.3
  • react@16.13.1
    added 1626 packages from 750 contributors and audited 1630 packages in 348.87s

59 packages are looking for funding
run npm fund for details

found 1 low severity vulnerability
run npm audit fix to fix them, or npm audit for details

Thanks!