Hello. I am getting errors while trying to install react app. Here is what command prompt

I have tried many things and haven’t found a way to solve for days.

It looks like you haven’t chosen a folder where you want to create the app. So the terminal tries to install in some temporary directory where you’re not allowed to install the app.

It is the F directory. I have tried to change it to C but it didn’t allow me to make this.

Did you try to create a folder for all your apps and Codecademy projects and install the new app inside that folder? That should work.

Hi @positivedev !

How are you? You have a problem with permissions, that’s why you can’t create your app. You can try several things to hang out a solution. Let’s start!

Try to make your folder manually. Steps to repeat:

  1. Navigate to /home/user/{xxxxx} folder
  2. Create a new directory
  3. Navigate to new directory
  4. Run npx create-react-app my-app

Also, you can try uninstall npm (npm uninstall -g create-react-app]) then try to create app [Perform this in C drive as per your image)

If this, doens’t work and it’s possible try to creat the app in a different drive.

Try to open your command bash as administrator.

Try installing it globally first, using the command

npm install -g create-react-app

And then, you can create your app using the command,

npx create-react-app <Name of your app>

This is occurring because windows is not giving permission to the user to create a folder inside system drive. To solve this:

Right Click

The Folder > Properties > Security Tab

Click on Edit to change Permissions > Select the user and give Full Control to that user.

I give you a list of solution, let me know if you can fix the problem! If not, reply with more information.

See u.

I am getting this error while trying to create under a different folder in F disk.

Also, I cannot change the permissions of this disk.
How can I change the working directory to C disk? When I try to change it with cd /C: command, it gives error.

I have already created a new folder under F. You can read the following answer replying to @erodriguez101

Looks like you installed react globally – which is a problem. So try to uninstall the global installation:

npm uninstall -g create-react-app

And then navigate to the folder you created and install the app locally:

npx create-react-app myfirstreactapp

Here is the same error

Ok. I have found out the solution.

  1. Before running the command prompt, right-click on its icon and select “run as administrator”
  2. Change the drive to F: and go to a child directory (in my case, it was the folder “react”)
  3. Run the npm install -g create-react-app and npx create-react-app respectively
  4. Then, go to that child directory and run npm start command.

npm start will open a window on the default browser. In order to show your own message, try to edit app.js file.

It took almost 20 days to realize that I needed to run the command window as the administrator. :joy: :joy: :joy: