Console not Displaying Correctly


#1

Hi Everyone & @zystvan -

Quick question - I started with the JavaScript (haven't tried the others yet) course and for some odd reason, all text seems to be right-aligned. I can't see the majority of the text, as some of it fall behind the console and with some of the variables, everything seems to be swopped around.

I've checked whether any of my chrome extensions are doing this, but nothing. Even tried it in Edge and Safari.

I use a Macbook Air, using Chrome.

Any idea why this would be?

Thank you,
Tiaan


#2

If you're displaying the page in a very small window, perhaps's that's causing it? If so zooming out might get around it.
Not entirely clear on what you're seeing, screenshots generally describe such things better and more accurately.
If copying and pasting is still functioning correctly then a work-around could be to use a local editor, obviously you'd be using vim since that's the only sane editor ever.


#3

[discussion continued from Twitter]

@tvz89 Since it looks like the text direction got switched from the default left-to-right to right-to-left, at first I thought this Super User answer might help, but then I tested it and it didn't, so that's not helpful, I guess :confused: (I'm leaving it in case it ever helps anyone, though)

Does the homepage look odd as well, or is it only these exercise pages?


Related topic: Site doesn’t display correctly - the problem there was a browser addon reversing the text direction.


#4

Is this a demo, of some sort? May we see the raw JavaScript (the code, not a picture), please? Also include a link to the exercise. Thanks.


#5

It is only in the exercise mode. I don't see the same problem on any other page i.e. homepage. This is what the screen looks like:

As you can see, the text goes from right to left, with the punctuation all flowing to the left of the sentences.

See the next post for another screenshot

Thank you


#6

This is the source of the same page:

I hope these screenshots help.


#7

What does the CSS class ''undefined" look like?


#8

@tvz89 Thanks for the screenshots, I'm still having a hard time figuring out what might be wrong :confused:

What's your browser locale set to?
Have you tried disabling all browser extensions?
Did you run any updates on your computer recently, or change any settings?


#9

@zystvan It is a mystery to what the problem might be.

  1. It is set to English
  2. I've disabled all my browser extensions to try it, but nothing changed.
  3. I update my mac software regularly (when available), but would an update of software (if impacting), not impact more than one website?

If I look at the source, there seems to be quite a lot of CDATA text. When I open the CSS link in its separate tab, it shows the same CDATA text. This is the link I used - https://cdn-production.codecademy.com/assets/application-rtl-5b7da64d64ea4a18240d774774a9fb4e.css

Here is a screenshot of that -

Not sure if that helps.

Please let me know if you need anything else.

Tiaan


#10

@tvz89

Is the URL you're on https://www.codecademy.com/ar/courses/getting-started-v2/1/3? Changing the ar to en should fix it :slight_smile:


#11

Haha simple solution to a long thread. Why was it /ar/ in the first place?

Thanks @zystvan


#12

@tvz89

Why was it /ar/ in the first place?

I have absolutely no idea, sorry ¯\_(ツ)_/¯