Conditionals and Control Flow Bug


#1

I just started with conditions and control flow in python. I think there is a bug. First there is the clinic example. i input right and then it takes me to the next page where we have to input true or false for booleans. But, it is repeating the welcome to clinic question again and again.


#2

Please post a link to the exercise(s) so we can check it out. Thanks.


#3

www.codecademy.com/courses/learn-python/lessons/conditionals--control-flow/exercises/compare-closely?action=lesson_resume


#4

I’m seeing the code from lesson 1 in the editor for lesson 2, but only for an instant, then it is replaced with the boolean questions for which we only need to finish each statement with True or False, according to our evaluation of each expression. Are you not seeing this?


#5

No , the code remains. Tried it on two different laptops. Same problem.


#6

I have been unable to reproduce the problem. @bitsurfer32104, did you make any changes at all to the code in the clinic example? If not, then this seems like a bug. Assuming that Codecademy has awarded you the point for that exercise, you may be able to work around the bug by first refreshing the clinic example page, then removing this last line of code, and finally by submitting the code again …

clinic()

Removing that function call should prevent the clinic function from executing. After that, you should be able to proceed to the next exercise.


#7

Thank you for your help. But , I think code academy fixed the problem. I can now proceed to the next lesson without any errors


#8

I am too having this problem, I took away the clinic function it’s still not letting me go to the next lesson


#9

@flf4micagmail.com,

Did you remove only this statement …

clinic()

… or did you remove additional code as well?

After you remove the statement, you might have to refresh the page, and click the Run button again.

The problem does not appear to be caused by the submission correctness test (SCT) that is specific to this exercise. As designed, it should award the user credit as soon as the code completes execution.

Codecademy staff do read the forums, and will need to correct this problem.


#10

Finally. It’s fixed, thank you so much


#11

2 posts were split to a new topic: Is this bug or have i change program by mistake?


#12