"command not recognized" Error on MessengerApp, Exercise 1


#1

I am also having this problem.

I restarted the "Saving Data" exercise, which I was about 20% through, but after restarting the mock terminal doesn't seem to work anymore. I was able to make a new Rails app, and then that was it.

I typed:
rails new MessengerApp

and everything went well. Then I typed:
cd MessengerApp

and I got "command not recognized"

So I thought maybe I accidentally navigated to a weird place, so I typed:
pwd

and I got "command not recognized"

So I typed:
ls

and I got "command not recognized"

I tried re-restarting the exercise, even though that was what caused the issue in the first place, and the problem persists. I've restarted it about 3 or 4 times now. The mock-terminal had been working just fine until the restart.


#2

@steenaire MessengerApp is in a different unit than this if I remember correctly. Could you please post a link to the exercise you're on?


#3

Oh, yea no problem. Sorry about that, I didn't want to start a new topic because this sounded like the same issue (albeit a different exercise), so I thought it would be more considerate to comment here.
This is the exercicse I'm on:
https://www.codecademy.com/en/courses/learn-rails/lessons/one-model/exercises/one-model-request-response-cycle


#4

@steenaire Thanks, I understand that but I've split this into it's own topic anyway :slight_smile:

Did step 1 get marked as complete before you ran cd MessengerApp?


#5

Yes, step 1 gets marked as complete after I type 'rails new MessengerApp' as it does seem to create the app at that point. But then I cannot change directories to run bundle install, etc, because it says cd is a 'command not recognized.'


#6

@steenaire Could you try resetting the exercise one more time, then going through it in a different browser?


#7

Alright, I've tried this in Firefox and in Chrome several times now, and the problem persists.

I've tried resetting the exercise in one browser, then starting it in the other - as well as both resetting and starting it in the other browser.

I've tried every permutation of browser and exercise-restarting-order, but all have the same outcome: "command not recognized."


#8

OK I just figured out a way to work around it.

I opened the exercise, and typed loads of stuff, pressing enter every time (and getting "command not recognized" every time, and causing the second point - "Run Bundle Install" to flash red every time I did a thing that was not bundle install).

I kept doing this until the exercise got exasperated and said, "Need help?" and I clicked "get code" and it fixed the terminal. Now it works!

Edit: Well, sort of.

Apparently now in the next exercise, the MessengerApp is gone, and there is no such directory. I tried to make it again, as I've had to re-create apps for several previous exercises (I think they go in a tmp file or something that gets cleared periodically), but now there is the inverse problem - the regular bash commands work, but rails commands don't work!

Oh well, even though all the rails commands don't work, the exercise is recognizing that I'm entering them, and is marking them off as complete. I think I'll just go through the motions for this exercise just so I can unlock the next one, and I'll bet the next one will be in-tact.

I'll just be sure to never ever restart it!


#9

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.