Command Line will not allow me to type ~

As you can see, I can type the ~. It’s telling me to type

nano ~/.bash_profile

I can type the symbol fine, I am on a mac and I have Character Viewer open, I can type it as much as I like anywhere

But in the code academy command line exercise 
[https://www.codecademy.com/en/courses/learn-the-command-line/lessons/environment/exercises/nano?action=resume](https://www.codecademy.com/en/courses/learn-the-command-line/lessons/environment/exercises/nano?action=resume)
It does not show up, so I am unable to pass the lesson. I really want to finish this so plz help :tired_face:

HI you can try to press…

cmd + 126
  • paste it in
  • navigate to $HOME and edit .bash_profile
  • add it programmatically to your history and then press UP
$ printf "\176\n" >> $HOME/.bash_history

er…how do you do that? I tried typing it?

Tried it… i probably did something wrong it didn’t work

you can see it here

My keyboard does not allow me to type a character used in a Codecademy lesson. What should I do?

I’m confused. In the command line do I type Alt + 126, or do I press the alt button on my mac and type 126???

Probably takes less time to try both than to type out the message you just posted?

1 Like

do I press the alt button on my mac and type 126?

yes do that .

well, I did that and I got:
¡™§
trying it again differently:
⁄€fl
I’m probably doing it wrong, or it’s a mac.

maybe it’s diff on mac … Becasue it work on windows

Stupid macs… screwing up my coding

I forgot that you need to reload history afterwards.

$ printf "\176\n" >> $HOME/.bash_history
$ history -r   # read history file

Did this:

$ printf "\176\n" >> $HOME/.bash_history
$ history -r

in the command line
Err… So embarrassed, not working.

you can try the option 5 in this link Option 5

the command line will not allow me to copy paste into the editor, or else I would have

I tried this:
`¡™£¢∞§¶•ªº–≠œ∑´®†¥¨ˆøπ“‘«åß∂ƒ©˙∆˚¬…æΩ≈ç√∫˜µ≤≥÷
Not the character i needed

and the Mac OSX option

I actually have that, and i can type the things anywhere ~~~ using the character/keyboard viewer, but the second I go into the command line thing it does not allow me to.

did you try another browser(s)