Command Line: Attica project

I’m at the first task in attica. I type pwd and nothing happens.

When you ask a question, don’t forget to include a link to the exercise or project you’re dealing with!

If you want to have the best chances of getting a useful answer quickly, make sure you follow our guidelines about how to ask a good question. That way you’ll be helping everyone – helping people to answer your question and helping others who are stuck to find the question and answer! :slight_smile:

https://www.codecademy.com/courses/learn-the-command-line/projects/attica

Hey there @progresspanda!

The project works fine for me.

I typed pwd and /home/ccuser/workspace/clothing was printed.

My first thought would be to check what browser you are using. Codecademy recomends using Chrome or Firefox. Troubleshooting Guide

1 Like

Did that. No difference in result.

Very odd indeed, have you tried everything in the Troubleshooting Guide?
Such as clearing browser caches and seeing if any extensions are interferring with Codecademy.

I’d be very interested in knowing where this “troubleshooting guide” is.
However, I’m far more interested in the “Contact Us” page. I’ve already ascertained that I can’t get my $240 back but the least they deserve is a nasty letter. How do you learn anything when it glitches so much?

I posted a link to it a few posts back, here it is again though: Troubleshooting


How long ago did you contact CC? If I remember correctly they attempt to respond within 48 hours.

As I said earlier, I cannot find any such thing as a Contact Us page.

The link to the help page is located in the footer on the main page.

You can click this link though.
In the top right corner is a blue button that says ‘Contact Us’

I found the link to CC just now. Now I can take it up with them and it won’t be pretty. Thanks very much for your assistance.

Your welcome.
Happy to help

Though I will say I have used their customer support before and can give high praise to them.
They were quick to fix my problem, and very friendly.

1 Like

source ~/.bash_profile drop dead md =“mkdir”
$ alias md= “mkdir”
bash: alias: mkdir: not found

Task 16 is giving me problems.
sed -i ‘s/Lingua-Franca/Lingua Franca/g’ /.txt
sed: 1: “/.txt”: invalid command code *

I dont understand why this isnt working. After figuring out the code myself I looked at the solution and still get the same error.

What am I doing wrong…

-> sed -i ‘s/Lingua-Franca/Lingua Franca/g’ /.txt

sed: 1: “africa/afrihili.txt”: command a expects \ followed by text

now I get this error code. Please help

Remember to wrap your code either with backticks or the </> text formatting button as your * characters have been used for formatting the text on this forum.

This would be the Lingua Franca project rather than Attica, yes?
https://www.codecademy.com/courses/learn-the-command-line/articles/command-line-offline-project

2 Likes

Apologies for adding to an existing thread but the following seems to cover issues many folks have had with step 16 of the Lingua Franca project (particularly those on OSX).
See the following thread (read the replies) for more details on the issues where the sed version differs from normal:

Sorry and yes didnt realize I was in the wrong thread.