Command Line 14% Exc 7/9

Excersise 7 of 9 in Command Line keeps erroring. The error message I recieve is below. The error occurs whenever I type ANYTHING including typing in the answer as listed below as well. I have reset the excercised. I am using firefox browser. When I enter my answer, I do not receive an error via the command line terminal. I recieve a code academy error, denoted by the red box at the bottom of the screen.

I have reported this as a bug twice over the past 20 days, 10 days apart. Is/ has anyone else experienced this error? Is there a way to skip an excercise in Code Academy?

All/ any help would be appreciated.

Cheers,
nicbono.

My Answer:
$ cd /home/ccuser/workspace/blog/2014/dec

Error:
“Use the change directory command to switch into the 2014/dec/ directory.”

Question Context:
The mkdir command stands for “make directory”. It takes
in a directory name as an argument, and then creates a new directory in
the current working directory.
Here we used mkdir to create a new directory named media/ inside the feb/ directory.

Steps:

  1. Navigate to the 2014/dec/ directory.
    List all files and directories in the working directory.
    2.Then type
    “touch keyboard.txt”
    Again, list all files and directories in the working directory. You’ll see that there is now a new file named keyboard.txt.

Hm… I am using a firefox browser and those exercises never errored.

Maybe, you have to update the firefox browser? Anyway hopefully, it works again. And/Or codeacademy helps!

Happy coding!

~Candycornlover1

It’s probably looking for cd 2014/dec (relative from current directory, not absolute path)
A lot of tests are on what you type, not on what effect it had :confused:

Hi ionatan,

Even when I started again from excercise 1 the same error occured at the same point.
So further to your suggestion, unfortunately even though I was at the most approrpiate path based on previous excercises I still recieved an error.

I will attempt it again though making sure I make no mistakes and enter in the ideal text and let you know how I go.

Is there any chance you have done the excersie and are able to provide me with all the lines of code you used?

Cheers,
nicbono

brb I’ll check what it’s looking for

It’s looking for either of:
cd 2014/dec/
cd 2014/dec
And it has to be successful, so you should enter either of them from ~/workspace/blog (assuming that’s where 2014 is located, that’s what you you said with /home/ccuser/workspace/blog/2014/dec

Could also cheat it with:

mkdir -p 2014/dec
cd 2014/dec

since the command will be successful if the directory exists
…but if you have to do that then there might be something wrong with what files are there

Hi Ionatan,

I restarted the training and managed to overcome the error similar to what you suggested

Thank you for your efforts! I think this is resolved :slight_smile:
althought I will note some sadness towards the truth behind your statement. I wish the tutorial was not based of writing exactly what you write as apposed to what effect I have made.

Cheers,

nicbono

I’m a bt stuck here as well and confused, I’ve hit cd 2014/dec in the command line but its saying the below:

bash: cd: 2014/dec: No such file or directory

So I thought its best to see what directory I’m in at the moment, so I hit pwd and I just get the below:

/

Any advice?

solved my own answer, a simple reset exercise solved it…strange

i had the same issue and did reset the exercise and it sorted out. Thanks for the idea

1 Like

Even though I entered the code correctly, I keep getting an error in this exercise. I reset the exercise multiple times but nothing changed. Can anyone help with the issue please.