Codecademy Workspace Problem

I have a problem with Codecademy, where when I accidentally deleted all the code, I clicked “Reset Workspace”, but unfortunately, the button did nothing. I experimented by doing errors on the workspace, but each time the button did nothing. I think that this may be a very critical error, and I hope it gets fixed soon. Thank you! :wink:
https://www.codecademy.com/courses/introduction-to-javascript/lessons/control-flow/exercises/true-false-values?action=resume_content_item

1 Like

It’s maybe a bug, report it. There is an article on how to do this(“just in case”).


There is an option to report a bug while doing a session, just click on report a bug and be descriptive as much as possible so they can find the bug and fix it(I think this isn’t that much necessary because this is a smaller bug)

1 Like

I have this problem too, and reported it. No response so far (after two days).

I found an earlier similar report from a couple of years ago. The advice then was to switch browsers and/or delete & reinstall the browser (!!!), and then the topic was closed.

I did try moving from Chrome (my default) to Firefox, but the problem persisted.

1 Like

What exactly is the issue? Just FYI, when you click the Reset button, it resets the exercise as if you just started it for the first time. That is what it is supposed to do. If you accidentally delete your code, clicking Reset will not bring it back. If you are having an issue that is other than I’ve described, post a link to the exercise, and I’ll take a look.

Hi. What’s happening is that this particular exercise is one that begins with some initial code (a couple of array declarations); the user is supposed to add code below this. However, I made some mistakes and accidentally deleted the original arrays. I tried to reconstruct one of them, but it was wrong.

Then I hit the Reset button and it did nothing. It left the exercise exactly as I had it immediately before. It didn’t wipe anything or restore the original state of the exercise.

Here’s the URL of the specific page I encountered this problem on: https://www.codecademy.com/courses/introduction-to-javascript/lessons/arrays/exercises/let-const-arrays

P.S. Since commenting, I found that I’d taken a screenshot of the original state of the page, so I was able to restore its original state by hand and complete the exercise. But I just verified that even now, the Reset doesn’t work.

2 Likes

You are absolutely correct. That is a bug. The reset button is essentially doing nothing. I have access to another error reporting avenue. I’ll write this up, and we’ll see what happens. Thanks for reporting this @byte0814775776!

Update: It’s been submitted. I’ll try to keep you informed of any progress.

1 Like

I’ve been told by a Codecademy team member that the issue has been fixed. Let me know if you notice any continued issues. I haven’t checked it out for myself yet.

Update: Seems to be working fine now.

the issue is not fixed. I have the problem in a typescript project (26. April 2022). I lost the boilerplate code and can’t get it back. I signed out/in and tried other browser but it didn’t help. I reported the bug.

1 Like

Can confirm, still bugged

I worked on my workspace for a while… A few days later I returned to my workspace to see the html file was gone. Is there any way I can get my code back?