Codecademy not running and Android tablet


Is Codecademy designed to work on Android OS? I can’t do the PHP exercices on my old Android tablet running Android Jelly Beans…It’s all messed up in the console…

Any way to do it?

request the desktop version of the site, still not very pleasant, but maybe something better

Codecademy isn’t designed for mobile devices (There are plenty of topics about this)

I never understood how people are able to code on tablets. All the weird symbols you need on your keyboard are difficult to reach, and most tools aren’t designed for tablet

1 Like


As far as I can remeber I did use the desktop version of the site under Mozilla Firefox and Google Chrome running on Android Jellybeans, but still same problem.

Moreover I was planning to use a nomad USB keyboard to plug on my Android tablet, with all standard keyboard keys, so no problem.

BTW, would Codecamy work better on a more recent Android tablet (with Android Lolipop for example?)

And would Codecademy run on a Chromebook (Chrome OS?) I can buy a cheap one …


codecademy focus isn’t on making the site mobile suitable

but that still won’t make it work, nor with usb keyboard nor a newer android version

Yea, it should run fine on chromeOS. i use linux as well, works like a charm

Thanks very much stetim94 for your feedback.

Since a few weeks I use extensively at Work on a desktop PCrunning Windows 7 and with Firefox ESR. It works like a charm, like you said :slight_smile:
However we do have a strict proxy on our network, and I believe that sometimes some third party plug ins like Java , Flash and others could get filtered and deactivated…What do you think? Could this be the source of the error messages the Codecamy sandbox system gives me when my code is 100% correct? (example: “inheritance” exercice in PHP course…Stick since a few days and 100% correct code…)

90% of the time there is a problem in the code, but for that you would have to make a new topic on the forum

Very unlikely if you can pass one exercise, another one is blocked by the network settings

I already created the topic last week, you should check:


I tried downloading and using the CodeAcademy Go app, butt launching it produces an error. The error says that a JS (java script) request was made by the app, which failed because of a ‘bad application bundle’.

I am using codecademy on my galaxy s7 tab. But neither on chrome nor on edge it is working well. The button to get to the next topic ( which is placed on the buttom of each site) cant be displayed. So i have to go back to the dashboard each time i finsh a topic and resume from there.
That is very pitty because it could be very easy just to place the navigation button above the main content