Code not loading


#1

I'm in the middle of this unit (on Neighbourhood Guides: Grid) and suddenly codecademy's website just won't load my new code at all. The browser tab just does that little circle that means it's sending forever and ever but the preview never updates and I can't submit (again, sending forever). Has anyone else had this problem? I'm using firefox 43.0.3. Everything was working fine until this lesson.

Oh wait. I might have updated my Java. Would that be a problem? How do I fix it?


#2

I've never heard of this happening in the Make a Website course. Is it still doing this?


#3

Yep. I've tried several times over the last few days. No change. Other courses are working fine.


#4

It looks like the version of my HTML that it has loaded for some reason has an un-closed quotation, which would explain why the preview can't load. But even after I close the quotation and go through and make sure all the tags are closed, it's like the changes to that HTML don't get successfully sent to the server.


#5

More info: Other lessons in this same course are having the same problem, even though they don't have syntax errors in the HTML. The preview won't load and my HTML changes never get sent to the server.


#6

Yet more info: It's not just an HTML issue. The PHP course, which is also asking your servers to load and render my HTML, is running fine (for now).


#7

I would not be surprised to hear that the PHP courses weren't loading so hearing about your experience is extra strange.

Let's just start with using the Reset Code button, and then reloading/refreshing the Neighbourhood Guides: Grid page.

Which OS/browser combination are you using?


#8

I have already tried both of those things. No change.

I'm using Firefox 43.0.3 on Mac OS X Yosemite (10.10.5)


#9

The next thing to check are your extensions and plugins. Turn them off and see if that helps.

Or you could try a different browser.


#10

Switching to Safari seems to have fixed it, but that's not really a functional solution. I didn't add any ad-ons to my Firefox before it started failing, so I doubt that's the issue. Maybe it's a cache/cookie thing? Are my inputs stored client-side?


#11

I don't know the answer to that, sorry.

It is working fine for me on Firefox 43.0.4 on Mac OS X Yosemite 10.10.5 so there must be something different, I just don't know what.


#12

Okay, well I finished that course in Safari. If the error recurs I'll come back, but for now I'm done debugging this. Thanks for all your help.