Click on "View Recipes" does nothing


#1

Help! I can't move forward on this exercise. I click on the "View Recipes" link and access the recipes but the exercise doesn't unlock. I'm stuck at the 4th exercise of the Authentication section. I restarted the exercise more than 4 times and refreshed the page. Still nothing. I can't continue working on the Rails Authentication course...

Link to the exercise:
https://www.codecademy.com/courses/rails-auth/lessons/authorization/exercises/authorization-authorization?action=lesson_resume

The only error message that I have is: Click on a "View Recipes" link to see the recipes inside a cuisine. It's so frustrating! I have reported a bug already but didn't get any response. This happened to me earlier in another section, the only way to move forward was to wait until the "Get code" option appeared on a pop-up and clicked there. Then, every step was marked in green and I could pass. Not in this case, though. (I also reported a bug on this one yesterday)


#2

Hi @groundberry,

Could you try switching browsers? That can often help with issues like this.

I have reported a bug already but didn't get any response.

Staff doesn't reply to reports issued through that form, it's only for you to communicate to them. If you'd like them to respond back to you, you can file a report through the help desk: https://help.codecademy.com/hc/ (although, I'd suggest you use the exercise form since it makes it easier for staff to get statistics on which exercises have bugs)


#3

I tried Firefox and can't connect to localhost:8000...


#4

Would running rails s -p 8000 in the terminal bring it up? Otherwise you might just have to wait for staff to fix the bug.


#5

No, It doesn't work... but thanks for trying :slight_smile: I'll wait until they fix it. It would be nice to have a button somewhere to skip and go to the next section. I saw a pop up with a button to get the code the other day and that's how I could continue working, but this time it's not coming up :slight_smile:


#6

Type in brouser localhost:8000/cuisines/1

That will solve your issues


NEXT button is not activated even after completing instruction
#7

That worked! Thank you! :sweat_smile:


#8

yes is did work thanks your the man!


#9

This topic is solved.